Bug 671361 - Device 0 (VID=03f0 and PID=0217) is UNKNOWN
Device 0 (VID=03f0 and PID=0217) is UNKNOWN
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
: 671492 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-21 07:02 EST by Martin Kho
Modified: 2011-01-25 17:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-25 17:33:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2011-01-21 07:02:56 EST
Description of problem:

I report this because of the following statement: "Please report this VID/PID and the device model to the libmtp development team"

Output of lsusb:
Bus 008 Device 003: ID 03f0:0217 Hewlett-Packard LaserJet 2200
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x03f0 Hewlett-Packard
  idProduct          0x0217 LaserJet 2200
  bcdDevice            1.00
  iManufacturer           1 HewLett Packard
  iProduct                2 HP LaserJet 2200
  iSerial                 3 00FRHRG20909
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           78
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xc0
      Self Powered
    MaxPower                2mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass         7 Printer
      bInterfaceSubClass      1 Printer
      bInterfaceProtocol      3 IEEE 1284.4 compatible bidirectional
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval             255
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       1
      bNumEndpoints           2
      bInterfaceClass         7 Printer
      bInterfaceSubClass      1 Printer
      bInterfaceProtocol      2 Bidirectional
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       2
      bNumEndpoints           1
      bInterfaceClass         7 Printer
      bInterfaceSubClass      1 Printer
      bInterfaceProtocol      1 Unidirectional
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
Device Status:     0x0001
  Self Powered

Version-Release number of selected component (if applicable):
libmtp-1.0.4-2.fc15.x86_64

How reproducible:
I came across to this 'issue' when Amarok (KDE music player) crashed. In .xsession-errors the following messages appeared:
"
QObject::connect: Cannot connect
Meta::MediaDeviceHandler::incrementProgress() to
(null)::incrementProgress()
QObject::connect: Cannot connect
Meta::MediaDeviceHandler::endProgressOperation(QObject*) to
(null)::endProgressOperation(QObject*)
Device 0 (VID=03f0 and PID=0217) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development
team QObject::connect: Cannot connect
Meta::MediaDeviceHandler::incrementProgress() to
(null)::incrementProgress()
QObject::connect: Cannot connect
Meta::MediaDeviceHandler::endProgressOperation(QObject*) to
(null)::endProgressOperation(QObject*)
ignoring usb_claim_interface = -16ignoring usb_claim_interface =
-22PTP_ERROR_IO: failed to open session, trying again after resetting USB
interface
inep: usb_get_endpoint_status(): Input/output error
outep: usb_get_endpoint_status(): Input/output error
usb_clear_halt() on IN endpoint: Numerical result out of range
usb_clear_halt() on OUT endpoint: Numerical result out of range
usb_clear_halt() on INTERRUPT endpoint: Numerical result out of range
LIBMTP libusb: Attempt to reset device
unnamed app(1606): Communication problem with  "amarok" , it probably
crashed. Error message was:  "org.freedesktop.DBus.Error.ServiceUnknown" :
" "The name org.kde.amarok was not provided by any .service files" "
"
Steps to Reproduce:
1. Start Amarok
2. Look into ~/.xsession-errors
3.
  
Actual results:
The device is probed, but the probing seems to be failing?

Expected results:
The device probing succeeds or have to be left out of probing?

Additional info:
The previous version (1.0.4-1) doesn't have this issue. May be patch "0001-Fixup-device-OS-descriptor-probe-code.patch" needs some fine tuning?
Comment 1 Kevin Kofler 2011-01-21 20:17:57 EST
*** Bug 671492 has been marked as a duplicate of this bug. ***
Comment 2 Linus Walleij 2011-01-24 13:35:08 EST
Argh I inverted the logic in the clever tests!

I have now pushed yet another version, now tweaking the right bits,
hoping it won't just provoke out the old error...
Comment 4 Martin Kho 2011-01-24 13:54:33 EST
Hi Linus,

I can confirm that the issue is solved with version libmtp-1.0.4-3.fc15.x86_64 (from koji). Please close this report.

Thanks,

Martin Kho

Note You need to log in before you can comment on or make changes to this bug.