Bug 671386 - Changes to messages returned by dmraid means stat() failures for dmraid setup on boot
Changes to messages returned by dmraid means stat() failures for dmraid setup...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
qe-baseos-daemons
:
: 690477 713792 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-21 08:40 EST by Ben
Modified: 2013-10-03 20:24 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to a change in a status message of the dmraid utility, the following error messages appeared on boot, when the previous version of the initscripts package was installed: failed to stat() /dev/mapper/no failed to stat() /dev/mapper/block failed to stat() /dev/mapper/devices failed to stat() /dev/mapper/found With this update, the /rc.d/rc.sysinit script has been fixed and the error messages no longer appear on boot.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 04:36:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
potential patch (552 bytes, patch)
2011-01-21 11:24 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Ben 2011-01-21 08:40:36 EST
Description of problem:

Since updating my RHEL5.5 server to RHEL5.6 I see this on boot:

failed to stat() /dev/mapper/no
failed to stat() /dev/mapper/block
failed to stat() /dev/mapper/devices
failed to stat() /dev/mapper/found


Version-Release number of selected component (if applicable):

RHEL5.6, initscripts-8.45.33-1.el5


How reproducible:

Every time.


Steps to Reproduce:
1. Update to the above RPM
2. Reboot
3. Read boot messages
  
Actual results:

dmraid detection stuff has problems.  Probably due to the result of /sbin/dmraid -s -c -i having changed to "no block devices found".


Expected results:

Clean boot.

Additional info:

This looks similar to https://bugzilla.redhat.com/show_bug.cgi?id=527726 but because of another change to the returned messages.
Comment 1 Bill Nottingham 2011-01-21 11:24:27 EST
Created attachment 474640 [details]
potential patch

Try this, if you have a minute? I'll try and check just how much of dmraid got backported.
Comment 2 Ben 2011-01-21 11:39:59 EST
Hang on, that's not going to work, is it?  I'm a bit sleepy at the moment but surely $? _is_ going to = 0 as my installation says "no block devices found".  As a result it's going to try doing the dmraid stuff.

The problem is that the message has changed, not that there's no message.

I'm perfectly willing to accept that I've grasped the wrong end of the stick here but changing "no raid devices found" to "no block devices found" in my rc.sysinit seems to have worked.  Isn't that, or an egrep for "^no " going to be a better plan?
Comment 3 Bill Nottingham 2011-01-21 11:58:15 EST
Current (i.e., Fedora) versions of dmraid throw an error code, not just a message, when there isn't anything found; this is obviously much easier to test and less prone to needing updates. The version originally in RHEL only just printed out a message, yet always returned success - that's why we were parsing the message.

If the current version has been backported wholesale, that change should work.
Comment 4 Bill Nottingham 2011-01-21 11:58:55 EST
What version of dmraid did you have previously, and now?
Comment 5 Bill Nottingham 2011-01-21 12:00:35 EST
Oh, this is fallout from the changes for bug 524356.
Comment 6 Bill Nottingham 2011-01-21 12:05:06 EST
This was fixed upstream with http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=4775714a975be6d799c12ccd17e3c1a4b89bafbc - this needs backported.
Comment 7 Ben 2011-01-21 12:17:22 EST
(In reply to comment #4)
> What version of dmraid did you have previously, and now?

From /var/log/yum.log*

yum.log.1:Mar 31 11:58:32 Updated: dmraid-1.0.0.rc13-63.el5.i386
(2010)
yum.log.2:Sep 11 09:57:55 Updated: dmraid-1.0.0.rc13-53.el5.i386
(2009)
yum.log.3:Nov 28 11:47:56 Updated: dmraid - 1.0.0.rc13-15.el5_2.1.i386
(2008)

It doesn't look like the change you mention in comment #3 has been backported.

[root@shelob ~]# dmraidsets=$(LC_ALL=C /sbin/dmraid -s -c -i)
[root@shelob ~]# echo $?
0
[root@shelob ~]# echo $dmraidsets
no block devices found
[root@shelob ~]#
Comment 8 Ben 2011-01-31 08:08:16 EST
Any movement on this?

Is the change going to be backported?
Comment 9 RHEL Product and Program Management 2011-02-01 12:07:16 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Bill Nottingham 2011-03-24 11:20:34 EDT
*** Bug 690477 has been marked as a duplicate of this bug. ***
Comment 13 Bill Nottingham 2011-06-16 15:27:58 EDT
*** Bug 713792 has been marked as a duplicate of this bug. ***
Comment 15 Tomas Capek 2011-07-13 08:25:47 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to a change in a status message of the dmraid utility, the following error messages appeared on boot, when the previous version of the initscripts package was installed:

failed to stat() /dev/mapper/no
failed to stat() /dev/mapper/block
failed to stat() /dev/mapper/devices
failed to stat() /dev/mapper/found

With this update, the /rc.d/rc.sysinit script has been fixed and the error messages no longer appear on boot.
Comment 16 errata-xmlrpc 2011-07-21 04:36:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1081.html
Comment 17 errata-xmlrpc 2011-07-21 08:40:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1081.html
Comment 18 Red Hat Bugzilla 2013-10-03 20:24:25 EDT
Removing external tracker bug with the id 'DOC-46472' as it is not valid for this tracker

Note You need to log in before you can comment on or make changes to this bug.