Bug 671508 - Calendar selection tool doesn't open if invalid date entered in text box
Summary: Calendar selection tool doesn't open if invalid date entered in text box
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Chris Duryee
QA Contact: J.C. Molet
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2011-01-21 17:34 UTC by J.C. Molet
Modified: 2011-05-19 13:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:39:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description J.C. Molet 2011-01-21 17:34:47 UTC
Description of problem:
If you are using the date selection widget in subscription-manager, it does not let you open the graphical date selection tool if you have a invalid date entered in the text box.

Version-Release number of selected component (if applicable):
subscription-manager-0.93.13-1.git.11.e083aba.el6.x86_64
subscription-manager-firstboot-0.93.13-1.git.11.e083aba.el6.x86_64
subscription-manager-gnome-0.93.13-1.git.11.e083aba.el6.x86_64

Steps to Reproduce:
1. Install subscription-manager-gnome and all its dependencies
2. Register rhsm
3. Open subscription-manager-gui
4. Go to the "All Available Subscriptions" tab
5. Erase the date in the date selection text box (or enter in an invalid date)
6. Click on the calendar button that lets you select the date graphically
  
Actual results:
The widget returns a "invalid date format" error, and cannot be used until a valid date is typed in.

Expected results:
If a invalid date is detected, it would open up the graphical selection tool so that I could select a valid date.

Additional notes:
If an invalid date is detected and the graphicl selection tool is selected, I could possibly enter in today's date in the text field, and then open up the tool.

Comment 1 Chris Duryee 2011-01-21 19:54:17 UTC
We added the text box for 508 compliance and QA automation, since users with screen readers can't access the calendar (see 670212 and https://bugzilla.gnome.org/show_bug.cgi?id=321123).

If we send the user from the text box to the calendar on error, they would be in a jam if they were using a screen reader.

I'm going to mark as NOTABUG, but let me know if you need anything altered, or want to discuss it further.

Comment 2 John Sefler 2011-01-24 16:23:46 UTC
I suggest the following be implemented:

* If the text-based-date-field is invalid when the calendar icon is clicked, return a "invalid date format" error as done today.

* If the text-based-date-field is blank when the calendar icon is clicked, enter in today's date in the text field, and then open up the
tool.

I think this will improve the usability in the case that a user has messed up the date string and just wants to erase their settings. and then use the calendar widget to do the hard work.

Comment 3 John Sefler 2011-01-24 16:28:59 UTC
Upon further review, I think jmolet's Additional notes is best:
If an invalid date is detected and the graphicl selection tool is selected, It
could correct the invalid date and enter in today's date in the text field, and then open up the calendar tool.

Comment 4 Chris Duryee 2011-01-24 20:36:34 UTC
I tried this out via Orca, and if I implemented the suggestion, then it would break the screen reader. I'm in Ann Arbor tomorrow, but I can show you what I mean on Wednesday if you like.

Comment 5 Chris Duryee 2011-01-28 14:41:56 UTC
this is fixed via the localized date example in the box. Altering to MODIFIED (I don't have VERIFIED in my dropdown, I think I don't have perms).

Comment 7 errata-xmlrpc 2011-05-19 13:39:06 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.