Bug 671534 - [abrt] xsane-0.998-1.fc13: e2_setup_block_mode: Process /usr/bin/xsane was killed by signal 8 (SIGFPE)
Summary: [abrt] xsane-0.998-1.fc13: e2_setup_block_mode: Process /usr/bin/xsane was ki...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xsane
Version: 13
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:56b81ce9cd66d5cbc72b60d11ce...
: 611881 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-21 19:00 UTC by Michal Jaegermann
Modified: 2011-03-07 18:16 UTC (History)
2 users (show)

Fixed In Version: sane-backends-1.0.21-6.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-05 02:37:26 UTC


Attachments (Terms of Use)
File: backtrace (23.34 KB, text/plain)
2011-01-21 19:00 UTC, Michal Jaegermann
no flags Details

Description Michal Jaegermann 2011-01-21 19:00:40 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: xsane
comment: This was a unique incident not observed before or after
component: xsane
crash_function: e2_setup_block_mode
executable: /usr/bin/xsane
kernel: 2.6.34.7-66.fc13.x86_64
package: xsane-0.998-1.fc13
rating: 3
reason: Process /usr/bin/xsane was killed by signal 8 (SIGFPE)
release: Fedora release 13 (Goddard)
time: 1295497648
uid: 401

How to reproduce
-----
It happened when attempting to change with a mouse scan boundaries in a preview window

Comment 1 Michal Jaegermann 2011-01-21 19:00:42 UTC
Created attachment 474659 [details]
File: backtrace

Comment 2 Michal Jaegermann 2011-01-21 19:17:56 UTC
This bug happened in e2_setup_block_mode() on line epson2-ops.c:1218 (backend libraries) in the following code:

1207            if (s->hw->connection == SANE_EPSON_SCSI)
1208                    maxreq = sanei_scsi_max_request_size;
1209            else if (s->hw->connection == SANE_EPSON_USB)
1210                    maxreq = 128 * 1024;
1211            else
1212                    maxreq = 32 * 1024;
1213
1214            /* XXX verify if this can b extended to other models */
1215            if (s->hw->connection == SANE_EPSON_NET && e2_model(s, "LP-A500"))
1216                    maxreq = 64 * 1024;
1217
1218            s->lcount = maxreq / s->params.bytes_per_line;
1219
1220            DBG(1, "max req size: %d, line count: %d\n", maxreq, s->lcount);
1221
1222            /* XXX investigate this */

gdb shows the following content of s->params:

{format = SANE_FRAME_GRAY, last_frame = 1, bytes_per_line = 0, 
  pixels_per_line = 0, lines = -5, depth = 8}

so a division by zero may indeed be not looked favourably upon.  maxreq was
set on lind 1210 as this is indeed SANE_EPSON_USB scanner.

Comment 3 Michal Jaegermann 2011-01-31 22:02:48 UTC
The same crash, exactly, happened again and in the same circumstances, i.e. while attempting to adjust via GUI a rectangle to be scanned.  So this is repeatable but I have no idea how to repeat that at will as after an xsane restart "the same" operation succeeded without any issues.

Comment 4 Nils Philippsen 2011-02-08 09:13:23 UTC
Bug #667858 is the same issue on F-13.

Comment 5 Fedora Update System 2011-02-08 10:28:39 UTC
sane-backends-1.0.21-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/sane-backends-1.0.21-6.fc14

Comment 6 Fedora Update System 2011-02-08 10:30:32 UTC
sane-backends-1.0.21-6.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/sane-backends-1.0.21-6.fc13

Comment 7 Fedora Update System 2011-02-08 22:54:48 UTC
sane-backends-1.0.21-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sane-backends'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/sane-backends-1.0.21-6.fc13

Comment 8 Fedora Update System 2011-03-05 02:37:20 UTC
sane-backends-1.0.21-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 info@kobaltwit.be 2011-03-07 18:16:33 UTC
*** Bug 611881 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.