Bug 67175 - Installer not running up2date -u
Installer not running up2date -u
Status: CLOSED RAWHIDE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-20 13:33 EDT by Matt Jamison
Modified: 2007-07-31 15:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 13:46:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Satellite installer console text (6.53 KB, text/plain)
2002-07-11 12:50 EDT, Josef Komenda
no flags Details

  None (edit)
Description Josef Komenda 2002-06-20 13:33:41 EDT
Description of Problem: Installer does not run up2date -u during install.


Version-Release number of selected component (if applicable): see bug 63780


How Reproducible: Always.
Comment 1 Adrian Likins 2002-06-20 14:10:27 EDT
um, yes it does.

more details please?

Did you choose to do the RHN check? if you didnt, then
it wont run up2date, otherwise, it should.
Comment 2 Josef Komenda 2002-06-20 14:34:23 EDT
Ran installer on satcd.rdu.redhat.com using rhn_train_3. Logging into
rhn.redhat.com using the rhn_train_3 usrname/password shows 73 errata and 112
packages apply to the system. up2date -l confirms this. 

GDK also has more details - seems satinstall.py has a bad path, using
/sbin/up2date instead of /usr/sbin/up2date.
Comment 3 Adrian Likins 2002-06-21 14:16:28 EDT
That path has been updated in cvs.

Is it still failing to run up2date?

What happens when it fails to run up2date? Error message?
Comment 4 Josef Komenda 2002-06-21 15:02:07 EDT
Will have to do a new installer build and test on a clean install... Luckily, I
happen to have one handy. 

There is no error when it fails to up2date - it just doesn't happen.
Comment 5 Josef Komenda 2002-06-25 11:59:26 EDT
Still failing to update the test machine - not throwing any errors either.
Bumping the severity up.
Comment 6 Adrian Likins 2002-06-25 16:33:59 EDT
No idea whats up. The code definately runs "up2date -u" 

Can you point me at a setup that this is failing on?
Comment 7 Josef Komenda 2002-06-28 11:06:41 EDT
What happens is that on a fresh satellite install, it does not run up2date -u.
If you install it a second time, on the same system, it does. You can, in fact,
go 'back' after registering the system, and then as you walk through the
installer again, it will run the up2date agent.
Comment 8 Adrian Likins 2002-07-01 13:43:19 EDT
code commited to clean up the only thing I could think
of that could be causing this.

Is this still not working?
Comment 9 Robin Norwood 2002-07-01 17:16:59 EDT
No, it still ain't working - using installer - installer_01jul02_1650.iso on
sat-live.test.redhat.com - it did not seem to run up2date - running the
installer a second time does run up2date at the proper time, however.

I did not register the system before running the installer - looking at the
account on live - rhn_train_3, the box did get registered twice....
Comment 10 Adrian Likins 2002-07-01 17:39:26 EDT
time for a version number in the installer...

I have no fucking clue what installer_01jul02_1650.iso
or what version of the installer...

I basically need to know "does the version in cvs _right_ now"
work?
Comment 11 Josef Komenda 2002-07-01 17:50:33 EDT
The installer_01jul02_1650.iso is the latest and greatest - it's
installer_date_time.iso, so it's the one I put together at 10 minutes to 5
today. The versions that exist are on http://zealot.devel.redhat.com/installer/ 

CVS tree and RPM (from QA) are pulled fresh on each installer build.
Comment 12 Adrian Likins 2002-07-01 18:06:40 EDT
okay, try the code in cvs now...

it should be version 0.99.1
Comment 13 Josef Komenda 2002-07-02 13:06:06 EDT
0.99.1 build tested, no joy. No change in symptoms.
Comment 14 Adrian Likins 2002-07-02 15:52:28 EDT
try 0.99.3
Comment 15 Josef Komenda 2002-07-03 11:22:04 EDT
Using installer built at 03-Jul-2002 10:49 from QA, CVS version .99.3.1, no
change, install fails. Perhaps there are rpm's missing? I notice that
up2dateAuth.py and transports.py were worked on, and those aren't in my download
tree:

up2date -d --nosig apache apache-devel mod_perl `up2date --showall
--channel=redhat-rhn-satellite-i386-7.2 | sed 's/-[^-]*-[^-]*$//' | grep -v tk`
Comment 16 Josef Komenda 2002-07-03 12:26:55 EDT
Sorry - that didn't make a lot of sense... just trying to be sure I'm
downloading everything I should for the iso built.
Comment 17 Josef Komenda 2002-07-10 16:59:20 EDT
Install working corrently with latest build, but up2date still fails to run.
Current process is: 
a. Welcome Screen: Click 'Next'
b. Installing Packages. When Done, click 'Next'
c. RHN Account Info: Enter the passwords and Proxy info.
d. Satellite Application: Hit 'Next' You'll see a gpg alert. Click 'yes'
e. Oracle Info: Click 'Back' 
f. Satellite Application: Click 'Back'
g. Log into your RHN account and delete the new Satellite
h. Go back to the installer and re-run from the RHN Account Info page
g. The up2date agent will run.

This only happens from a freshly installed box.
Comment 18 Adrian Likins 2002-07-10 19:02:28 EDT
I need help figuring this out.

Namely, the sat install and up2date logs immediately
after running the sat installer the first time. 

If you can catch the output from the installer to
a file, that would be useful as well. 

any other debugging info you can provide is helpful 
as well (since I cant seem to duplicate this in
any sort of useful manner). 

random guesses to the cause, things you observed
that may or may not be related, weird voices from
the back of your head, etc.

Everything to me looks correct, and so far, I've
been unable to not get it to work, so looking for
clues...
Comment 19 Adrian Likins 2002-07-10 19:38:54 EDT
grumble... 
just tried a fresh install from the auto-ks.sh

installed cvs

check out the code from cvs

make PREFIX=/ CDROM_PREFIX=/ sat-install

(pointed rhn_reg and up2date at qa by editing
the config file)

mkdir /RPMS
scp'ed the stack of rpms from zealot to /RPMS

export RHN_ENV_QA=1
satinstall

(it started up, installed the packages in /RPMS,
asked for rhn info, asked for sat ent info,
then fired up up2date....)

I was worried that maybe there was a rpm-4.0.3/rpm-4.0.4
issue with the db's causing problems, but that doesnt seem
to be the case. ditto with gpg keyrings and friends. 

Comment 20 Adrian Likins 2002-07-10 19:48:24 EDT
something doesnt sound right...

a. Welcome Screen: Click 'Next'
b. Installing Packages. When Done, click 'Next'
c. RHN Account Info: Enter the passwords and Proxy info.
d. Satellite Application: Hit 'Next' You'll see a gpg alert. Click 'yes'
e. Oracle Info: Click 'Back' 
f. Satellite Application: Click 'Back'
g. Log into your RHN account and delete the new Satellite
h. Go back to the installer and re-run from the RHN Account Info page
g. The up2date agent will run.


d. Satellite Application: Hit 'Next' You'll see a gpg alert. Click 'yes'

You shouldnt be getting that with the current code base. The installer
goes ahead and adds the key if it's not installed.

Looking at the code, I'm thinking the "gpg doesnt do anything at
all the first time you run it" must be causing the issue. 

APplying a bit of a kluge to fix that now.
Comment 21 Josef Komenda 2002-07-11 11:42:46 EDT
The latest version of the installer (built 10:55am with latest CVS and RPMS)
blows up instantly: 

Traceback (innermost last):
  File "/mnt/cdrom/usr/sbin/satinstall", line 793, in ?
    main()
  File "/mnt/cdrom/usr/sbin/satinstall", line 785, in main
    gui = Gui()
  File "/mnt/cdrom/usr/sbin/satinstall", line 104, in __init__
    satInstall.addGPGKey()
  File "/mnt/cdrom//usr/share/rhn/satinstall/satInstall.py", line 103, in
addGPGKey
    log.log("running %s to make sure gpg is initialized completely" %
gpg_command)
AttributeError: log

I'll run the last good version of the installer (installer_10jul02_1521.iso)
straight through, and precicely document my exact steps, and use 1>install.out
2>install.err to capture the output as well.
Comment 22 Josef Komenda 2002-07-11 12:02:44 EDT
Hmm... It hangs at the 'Installing packages' screen when I use 1>. Will do it
the normal way. Kickstarting again. 
Comment 23 Josef Komenda 2002-07-11 12:48:10 EDT
1. Auto-kickstart sat-inst.test. 
2. Download and mount installer_10jul02_1521.iso
3. Edit rhn_register and up2date
4. export RHN_ENV_QA=1
5. /mnt/cdrom/usr/sbin/satinstall
6. Gui fires up - 'Welcome'. I click 'Next'.
7. 'Installing Packages' runs, I click 'Next' when done.
8. 'RHN Account Information'. I enter rhn7_satellite and the password and click
'Next'. 
9. 'Satellite Application Server settings'. I enter my e-mail and rhn_train_1
satellite xert, and click 'Next'.
10. At this point, the GPG alert pops up, asking if I want to install the key. I
click 'Yes'.
11. 'Oracle connection information'. Everything continues as usual from here.

I'm attaching the console output and leaving sat-inst.test alone for review.

Comment 24 Josef Komenda 2002-07-11 12:50:33 EDT
Created attachment 64844 [details]
Satellite installer console text
Comment 25 Adrian Likins 2002-07-11 13:46:03 EDT
fixed in cvs, typo in a logging bit
Comment 26 Josef Komenda 2002-07-11 15:05:07 EDT
Runs up2date correctly now. Closing.

Note You need to log in before you can comment on or make changes to this bug.