Bug 67182 - g++ gave error on compilation of Qt
g++ gave error on compilation of Qt
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-20 14:02 EDT by John
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 17:27:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John 2002-06-20 14:02:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1) Gecko/20020508
Netscape6/6.2.3

Description of problem:
I was compiling Qt 3.0.4 (www.trolltech.com/products/qt/) and during "make", it
gave this error message and said to report it as a bug: 

g++ -c -pipe -Wall -W -O2 -fPIC -DQT_SHARED -DQT_NO_DEBUG -DQT_NO_NIS
-DQT_NO_REMOTE -DQT_NO_IMAGEIO_MNG -DQT_NO_IMAGEIO_JPEG -DQT_NO_STYLE_AQUA
-DQT_NO_STYLE_MAC -DQT_NO_STYLE_INTERLACE -DQT_NO_STYLE_COMPACT
-I../../../include/freetype2 -I3rdparty/libpng -I3rdparty/zlib
-I/usr/lib/qt-3.0.4/include -I../../../X11R6/include -I../../../X11R6/include
-I.moc/release/ -I/usr/lib/qt-3.0.4/mkspecs/linux-g++ -o
.obj/release/moc_qdial.o .moc/release/moc_qdial.cpp
In file included from widgets/qdial.h:43,
                 from .moc/release/moc_qdial.cpp:11:
/usr/lib/qt-3.0.4/include/qwidget.h: In method `bool QWidget::isDialog 
() const':
/usr/lib/qt-3.0.4/include/qwidget.h:684: Internal compiler error in pop_binding,
at ../gcc/cp/decl.c:
1218
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [.obj/release/moc_qdial.o] Error 2
make[2]: Leaving directory `/usr/lib/qt-3.0.4/src'
make[1]: *** [sub-src] Error 2
make[1]: Leaving directory `/usr/lib/qt-3.0.4'
make: *** [init] Error 2


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. run ./configure in Qt directory
2. then run make
3.
	

Additional info:
Comment 1 Richard Henderson 2004-10-02 17:27:47 EDT
QT has built since then.

Note You need to log in before you can comment on or make changes to this bug.