Bug 671880 - libdrmaa.so missing
libdrmaa.so missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gridengine (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-22 07:24 EST by Bernd Gloss
Modified: 2013-08-10 08:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: gridengine-2011.11p1-15.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 23:52:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernd Gloss 2011-01-22 07:24:12 EST
Description of problem:
The Java DRMAA abstraction drmaa.jar cannot find/load the libdrmaa.so library, which is located in /usr/lib64/libdrmaa.so.1.0. A soft-link
libdrmaa.so -> libdrmaa.so.1.0 is missing.

Version-Release number of selected component (if applicable):
Fedora14, gridengine 6.2u5

How reproducible:
Use a Java tool that tries to submit jobs via the DRMAA interface. Have drmaa.jar in the classpath of the JRE.

Steps to Reproduce:
Wow.... that is complex. I have a self-written tool issuing the DRMAA calls. If needed, I can provide some java test-code.
  
Actual results:
[sw:submit] java.lang.UnsatisfiedLinkError: no drmaa in java.library.path
[sw:submit] 	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1734)
[sw:submit] 	at java.lang.Runtime.loadLibrary0(Runtime.java:823)
[sw:submit] 	at java.lang.System.loadLibrary(System.java:1028)
[sw:submit] 	at com.sun.grid.drmaa.SessionImpl$1.run(SessionImpl.java:64)
[sw:submit] 	at java.security.AccessController.doPrivileged(Native Method)
[sw:submit] 	at com.sun.grid.drmaa.SessionImpl.<clinit>(SessionImpl.java:62)
[sw:submit] 	at com.sun.grid.drmaa.SessionFactoryImpl.getSession(SessionFactoryImpl.java:60)
[sw:submit] 	at gs.simtool.tools.SGESubmitter.<init>(SGESubmitter.java:52)


Expected results:
no failure.

Additional info:
-
Comment 1 Orion Poplawski 2011-03-11 10:39:37 EST
Why is it looking for libdrmaa.so rather than libdrmaa.so.1.0?  Any idea?  In the meantime you can install gridengine-devel to get the libdrmaa.so link.
Comment 2 Bernd Gloss 2013-07-29 09:51:56 EDT
Orion, 

I did a new installation of a F19 system last week and came across the same issue with this missing softlink again. 

I disagree with your "EasyFix" of installing the development package of gridengine. This solves the problem, no question. However, this link that allows the java library to access the ELF library is not specific to a software development task. It should rather work in any production system ... 

Kind regards,
Bernd
Comment 3 Bernd Gloss 2013-07-30 01:53:39 EDT
There is a blog description at Sun's web pages about this DRMAA interface from Daniel Templeton. https://blogs.oracle.com/templedf/entry/drmaa_providers 

There, he explains this DRMAA interface to access the grid and how it is (was) realized in this original Sun GridEngine: 

He also explains in the comments section in detail where/how the drmaa.jar java library expects to find the native libdrmaa.so library.

Daniel says:
--cut--
The problem is that DRMAA has a native component. The native component is found in $SGE_ROOT/lib/$ARCH/libdrmaa.so. In order for DRMAA to function, $SGE_ROOT/lib/$ARCH must be in your library path. The easiest way to do that with SGE 6.0 is to source the settings file (<code>source $SGE_ROOT/$SGE_CELL/common/settings.csh</code> or <code>. $SGE_ROOT/$SGE_CELL/common/settings.sh</code>) before running your application.
--cut--

I didn't check the original package coming from this SGE fork. I think the problem lies in this re-packaging for Fedora so that the library path now lies in /usr/lib64/

Also, Dan explicitly refers to drmaa.jar is looking for libdrmaa.so -- which is in line with this solution of simply adding this soft-link.

Bernd
Comment 4 Orion Poplawski 2013-07-30 23:19:36 EDT
Okay, you've convinced me.  Sorry it took so long.
Comment 5 Fedora Update System 2013-07-30 23:52:49 EDT
gridengine-2011.11p1-15.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gridengine-2011.11p1-15.fc18
Comment 6 Fedora Update System 2013-07-30 23:52:57 EDT
gridengine-2011.11p1-15.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gridengine-2011.11p1-15.fc19
Comment 7 Fedora Update System 2013-08-01 23:45:01 EDT
Package gridengine-2011.11p1-15.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gridengine-2011.11p1-15.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14026/gridengine-2011.11p1-15.fc18
then log in and leave karma (feedback).
Comment 8 Bernd Gloss 2013-08-09 00:52:59 EDT
okay for me...
Comment 9 Fedora Update System 2013-08-09 23:52:56 EDT
gridengine-2011.11p1-15.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-08-09 23:57:13 EDT
gridengine-2011.11p1-15.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-08-10 08:36:57 EDT
gridengine-2011.11p1-15.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-08-10 08:39:42 EDT
gridengine-2011.11p1-15.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.