Bug 67189 - sawfish-1.9.0-2.src.rpm fails to build (7.3-everything upgrade to Milan beta-2)
Summary: sawfish-1.9.0-2.src.rpm fails to build (7.3-everything upgrade to Milan beta-2)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: sawfish   
(Show other bugs)
Version: beta2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 69305 (view as bug list)
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-06-20 18:52 UTC by Glen A. Foster
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 20:24:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Glen A. Foster 2002-06-20 18:52:21 UTC
Description of Problem: SSIA.  Performing a re-build of sawfish from the SRPM
fails on an everything install of 7.3 then upgraded to Milan beta-2.  The build
gets an error on line 24 of the spec file (below).

Version-Release number of selected component (if applicable):
# ls -l sawfish-1.9.0-2.src.rpm
-rw-r--r--    1 root     root      1478907 May 28 14:21 sawfish-1.9.0-2.src.rpm
# md5sum sawfish-1.9.0-2.src.rpm
ef2214dcfb3932b4c8492403a239dd17  sawfish-1.9.0-2.src.rpm

How Reproducible: always (100%)

Steps to Reproduce:
1. 7.3 "everything" install
2. Milan beta-2 "everything" install
3. rpm -Uvh {distdir}/SRPMS/sawfish-1.9.0-2.src.rpm
4. rpmbuild -ba /usr/src/redhat/SPECS/sawfish.spec

Actual Results: The only line produced is as follows:

error: line 24: Unknown tag: LANG=C

Comment 1 Havoc Pennington 2002-07-12 22:20:24 UTC
Seems to work for me with latest.

Comment 2 Jay Turner 2002-07-18 15:52:33 UTC
With a fresh Milan-re0717.nightly tree, I am getting the same LANG=C message as
pointed out above.  This is for sawfish-1.9.0-3.

Comment 3 Havoc Pennington 2002-07-22 00:00:12 UTC
1.9.0-5 has a random stab at a fix, but if it doesn't work I'd guess this is an
RPM bug.

Comment 4 Havoc Pennington 2002-07-22 00:03:02 UTC
I take it back, the build system is horked so there's no 1.9.0-5 yet.

Comment 5 Havoc Pennington 2002-07-22 00:19:19 UTC
*** Bug 69305 has been marked as a duplicate of this bug. ***

Comment 6 Havoc Pennington 2002-07-22 00:20:36 UTC
#69305 argues it's an RPM issue. I think it's pretty obviously a change in RPM
behavior, if nothing else.

Comment 7 Jeremy Katz 2002-07-22 16:34:47 UTC
It's because the spec file references %install in a comment instead of using
%%install.  The spec file parser always expands macros when it sees them and so
%install gets expanded to a multiline bash script in a place where you can't
just randomly expand bash.

Comment 8 Glen A. Foster 2002-07-22 16:58:20 UTC
I still see the same behavior with Limbo, except that the only single line now
is reported with the error on line _26_ (used to be #24).

Comment 9 Michael Phillips, Jr. 2002-07-22 22:42:27 UTC
After editing the lines:
## If you add themes, be sure to add the tarball to the list
## down below in %install
to:
## If you add themes, be sure to add the tarball to the list
## down below in %%install
and recompiling sawfish.spec. You get the following error:

RPM build errors:
    File not found:
/var/tmp/sawfish-1.9.0-root/usr/libexec/rep/i386-redhat-linux-gnu/sawfish

In the %files section of the spec file, the macro %_target_platform expands
properly in the line --> %{_libexecdir}/sawfish/*/%{_target_platform} but does
not expand properly in --> %{_libexecdir}/rep/%{_target_platform}/sawfish

Comment 10 Preston Brown 2002-08-13 20:24:39 UTC
fixed in 2.0-2 and later.

Comment 11 Jay Turner 2002-08-21 15:30:29 UTC
Fix confirmed with sawfish-2.0-4.


Note You need to log in before you can comment on or make changes to this bug.