Bug 671900 - boot.iso/initrd.img supersedes install.img and squashfs.img in Fedora 15
Summary: boot.iso/initrd.img supersedes install.img and squashfs.img in Fedora 15
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-22 18:50 UTC by John Reiser
Modified: 2011-05-26 20:29 UTC (History)
7 users (show)

Fixed In Version: livecd-tools-15.3-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-27 20:08:12 UTC
Type: ---


Attachments (Terms of Use)
modified livecd-iso-to-disk (28.99 KB, text/plain)
2011-01-26 23:41 UTC, John Reiser
no flags Details

Description John Reiser 2011-01-22 18:50:27 UTC
Description of problem: livecd-iso-to-disk fails because Fedora 15 boot.iso no longer has install.img or squashfs.img in its ./images directory.  (Instead, everything is contained within isolinux/initrd.img which is about 145MB instead of its former 35MB.)


Version-Release number of selected component (if applicable):
livecd-tools-15.2-2.fc15.x86_64

How reproducible: every time


Steps to Reproduce:
1.https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB#How_to_Make_a_bootable_USB_Drive_to_Install_Fedora_instead_of_using_a_physical_DVD
2.
3.
  
Actual results: ERROR: path/to/boot.iso does not appear to be a Live image or DVD installer


Expected results: success


Additional info:

Comment 1 John Reiser 2011-01-22 20:19:00 UTC
After modifying the livecd-iso-to-disk shell script to ignore install.img, I produced a USB installer, and it boots.  But it assumes network install despite everything being on the USB flash memory.  Apparently the logic is not as trivial as my mods.

Comment 2 Brian Lane 2011-01-26 22:32:47 UTC
If it was made from a boot.iso it is a netinst image.

Could you attach the changes you made?

Comment 3 John Reiser 2011-01-26 23:41:00 UTC
Created attachment 475499 [details]
modified livecd-iso-to-disk

Here's how I attempted to work-around "no more install.img in Fedora 15." by changing the logic involving install.img in livecd-iso-to-disk.

Comment 4 Brian Lane 2011-01-26 23:57:29 UTC
Fixed with commit 0a7395c4ef9f38144275857213abc3c102faefc9

Comment 5 Fedora Update System 2011-02-19 02:18:24 UTC
livecd-tools-14.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/livecd-tools-14.2-1.fc14

Comment 6 Fedora Update System 2011-02-24 20:55:10 UTC
livecd-tools-14.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Luis A. Florit 2011-05-26 20:18:48 UTC
(In reply to comment #6)
> livecd-tools-14.2-1.fc14 has been pushed to the Fedora 14 stable repository. 
> If problems still persist, please make note of it in this bug report.

This is not a good solution, since someone could try to upgrade from other Fedora, like FC13 (my case). All livecd-tools need to be updated.

Comment 8 Luis A. Florit 2011-05-26 20:29:12 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > livecd-tools-14.2-1.fc14 has been pushed to the Fedora 14 stable repository. 
> > If problems still persist, please make note of it in this bug report.
> 
> This is not a good solution, since someone could try to upgrade from other
> Fedora, like FC13 (my case). All livecd-tools need to be updated.

... and livecd-tools-14.2-1.fc14.i686 fails miserably to install in FC13 by dependency reasons.

BTW... With the cheap and big USB pen drives that we have nowadays, isn't USB installs MUCH more common than DVD installs? So why USB install is so poorly supported in Fedora? I think that there should be an option in the Live media to install Fedora from a pen/hard drive ISO image directly.

Thanks,
L.


Note You need to log in before you can comment on or make changes to this bug.