Bug 671914 - [abrt] pyqtrailer-0.6.0-1.fc14: subprocess.py:1201:_execute_child:OSError: [Errno 2] Aucun fichier ou dossier de ce type
Summary: [abrt] pyqtrailer-0.6.0-1.fc14: subprocess.py:1201:_execute_child:OSError: [E...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pyqtrailer
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislav Ochotnicky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cabe0096
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-22 21:27 UTC by episol
Modified: 2011-02-09 20:22 UTC (History)
1 user (show)

Fixed In Version: pyqtrailer-0.6.2-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-09 20:17:06 UTC


Attachments (Terms of Use)
File: backtrace (1.64 KB, text/plain)
2011-01-22 21:27 UTC, episol
no flags Details

Description episol 2011-01-22 21:27:43 UTC
abrt version: 1.1.14
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/pyqtrailer
component: pyqtrailer
executable: /usr/bin/pyqtrailer
kernel: 2.6.35.10-74.fc14.x86_64
package: pyqtrailer-0.6.0-1.fc14
reason: subprocess.py:1201:_execute_child:OSError: [Errno 2] Aucun fichier ou dossier de ce type
release: Fedora release 14 (Laughlin)
time: 1295731589
uid: 500

backtrace
-----
subprocess.py:1201:_execute_child:OSError: [Errno 2] Aucun fichier ou dossier de ce type

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyqtrailer/main.py", line 367, in view_trailer
    subprocess.Popen(player)
  File "/usr/lib64/python2.7/subprocess.py", line 672, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1201, in _execute_child
    raise child_exception
OSError: [Errno 2] Aucun fichier ou dossier de ce type

Local variables in innermost frame:
errread: None
c2pread: None
gc_was_enabled: True
errwrite: None
shell: False
errpipe_write: 29
executable: 'mplayer'
close_fds: False
self: <subprocess.Popen object at 0x7f3f742e3890>
env: None
cwd: None
child_exception: OSError(2, 'Aucun fichier ou dossier de ce type')
args: ['mplayer', '-user-agent', 'QuickTime/7.6.2 (qtver=7.6.2;os=Windows NT5.1 Service Pack 3)', PyQt4.QtCore.QString(u'http://trailers.apple.com/movies/weinstein/thecompanymen/companymen-clip1_h480p.mov')]
fd: None
c2pwrite: None
data: 'cexceptions\nOSError\np0\n(I2\nS\'Aucun fichier ou dossier de ce type\'\np1\ntp2\nRp3\n(dp4\nS\'child_traceback\'\np5\nS\'Traceback (most recent call last):\\n  File "/usr/lib64/python2.7/subprocess.py", line 1157, in _execute_child\\n    os.execvp(executable, args)\\n  File "/usr/lib64/python2.7/os.py", line 344, in execvp\\n    _execvpe(file, args)\\n  File "/usr/lib64/python2.7/os.py", line 380, in _execvpe\\n    func(fullname, *argrest)\\nOSError: [Errno 2] Aucun fichier ou dossier de ce type\\n\'\np6\nsb.'
creationflags: 0
errpipe_read: 25
preexec_fn: None
p2cread: None
startupinfo: None
p2cwrite: None
universal_newlines: False

How to reproduce
-----
1.
2.
3.
lancement

Comment 1 episol 2011-01-22 21:27:46 UTC
Created attachment 474759 [details]
File: backtrace

Comment 2 Stanislav Ochotnicky 2011-01-24 08:40:53 UTC
This is caused by missing mplayer binary. Since Fedora repositories don't have mplayer, you'll have to use another player (or build your own). 

The exception itself is however a bug that I filed upstream:
https://github.com/sochotnicky/pyqtrailer/issues/issue/5

Comment 3 Fedora Update System 2011-01-31 10:05:34 UTC
pyqtrailer-0.6.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pyqtrailer-0.6.1-1.fc14

Comment 4 Fedora Update System 2011-01-31 10:05:41 UTC
pyqtrailer-0.6.1-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/pyqtrailer-0.6.1-1.fc13

Comment 5 Fedora Update System 2011-01-31 19:53:06 UTC
pyqtrailer-0.6.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pyqtrailer'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/pyqtrailer-0.6.1-1.fc13

Comment 6 Fedora Update System 2011-02-01 12:21:59 UTC
pyqtrailer-0.6.2-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/pyqtrailer-0.6.2-1.fc13

Comment 7 Fedora Update System 2011-02-01 12:22:06 UTC
pyqtrailer-0.6.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pyqtrailer-0.6.2-1.fc14

Comment 8 Fedora Update System 2011-02-09 20:17:01 UTC
pyqtrailer-0.6.2-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-02-09 20:22:39 UTC
pyqtrailer-0.6.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.