This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 672088 - qt-x11 pulls in phonon
qt-x11 pulls in phonon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: depchain
  Show dependency treegraph
 
Reported: 2011-01-23 16:42 EST by Rex Dieter
Modified: 2011-02-25 22:56 EST (History)
10 users (show)

See Also:
Fixed In Version: qt-4.7.1-17.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 660287
Environment:
Last Closed: 2011-02-25 22:56:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2011-01-23 16:42:57 EST
+++ This bug was initially created as a clone of Bug #660287 +++

Description of problem:

For installing keepassx, qt wants to pull in dependencies neither keepassx nor I am interested in:

===================================================================================================================================
 Package                               Arch                     Version                            Repository                 Size
===================================================================================================================================
Installing:
 keepassx                              x86_64                   0.4.3-1.fc14                       fedora                    796 k
Installing for dependencies:
 phonon                                x86_64                   4.4.2-1.fc14                       fedora                    162 k
 phonon-backend-xine                   x86_64                   4.4.2-1.fc14                       fedora                    161 k
 qt                                    x86_64                   1:4.7.1-3.fc14                     updates                   4.1 M
 qt-sqlite                             x86_64                   1:4.7.1-3.fc14                     updates                    54 k
 qt-webkit                             x86_64                   1:4.7.1-3.fc14                     updates                   5.3 M
 qt-x11                                x86_64                   1:4.7.1-3.fc14                     updates                    12 M

Transaction Summary
===================================================================================================================================
Install       7 Package(s)

Total download size: 23 M

There's no reason to pull in qt-webkit, qt-sqlite and phonon.

I looked up the way Debian does this:

http://packages.debian.org/sid/keepassx

There's a libqtcore, libqtgui and libqt-xml that are listed as dependencies.

--- Additional comment from rdieter@math.unl.edu on 2010-12-06 09:42:55 EST ---

Fwiw, we already split out qt, qt-x11, qt-webkit 

I see now that qt-x11 links libQtWebKit somewhere, which looks like a bug alright (-x11 is intended to be installable without -webkit).

--- Additional comment from rdieter@math.unl.edu on 2010-12-06 09:46:39 EST ---

Let's restore summary back, while we investigate the dep chain, then we can consider finer splitting.

--- Additional comment from rdieter@math.unl.edu on 2010-12-06 09:54:09 EST ---

/usr/bin/assistant-qt in qt-x11 links libQtWebKit

--- Additional comment from rdieter@math.unl.edu on 2010-12-15 12:43:18 EST ---

And, wrt phonon, did some digging on irc this morning,

$ for i in `rpm -ql qt-x11` ; do if [ -f $i -a -x $i ] ; then if ldd $i | grep phonon ; then echo $i; fi; fi; done
        libphonon.so.4 => /usr/lib/libphonon.so.4 (0x00a50000)
/usr/bin/assistant-qt4
        libphonon.so.4 => /usr/lib/libphonon.so.4 (0x00ef2000)
/usr/bin/qtconfig-qt4
        libphonon.so.4 => /usr/lib/libphonon.so.4 (0x00732000)
/usr/lib/qt4/bin/assistant
        libphonon.so.4 => /usr/lib/libphonon.so.4 (0x002e7000)
/usr/lib/qt4/bin/assistant-qt4
        libphonon.so.4 => /usr/lib/libphonon.so.4 (0x00766000)
/usr/lib/qt4/bin/qtconfig
        libphonon.so.4 => /usr/lib/libphonon.so.4 (0x0063d000)
/usr/lib/qt4/bin/qtconfig-qt4
        libphonon.so.4 => /usr/lib/libphonon.so.4 (0x00ec9000)
/usr/lib/qt4/plugins/designer/libphononwidgets.so

So, we have assistant, qtconfig, and qt4/plugins/designer/libphononwidgets.so pulling in phonon.  

assistant's phonon dep is coming from linking qtwebkit

qtconfig's phonon dep is from it's ability to tweak phonon (gstreamer) settings

the designer plugin libphononwidgets.so could be a problem... this is can be loaded at runtime from various places, including PyQt4/PyKDE4 and possibly  korundum (kde ruby bindings).
Comment 1 Rex Dieter 2011-01-23 16:43:38 EST
dup'd to track the 'qt-x11 pulls in phonon' part of the equation.
Comment 2 Rex Dieter 2011-01-25 15:06:30 EST
fixed in qt-4.7.1-10 (rawhide)

%changelog
* Tue Jan 25 2011 Rex Dieter <rdieter@fedoraproject.org> 4.7.1-10
- -config subpkg
- qt-x11 pulls in phonon (#672088)
- qtconfig.desktop: drop NoDisplay (f15+ only, for now)
Comment 3 Fedora Update System 2011-01-26 23:38:54 EST
qt-4.7.1-13.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qt-4.7.1-13.fc14
Comment 4 Fedora Update System 2011-01-27 15:56:04 EST
qt-4.7.1-13.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qt-4.7.1-13.fc14
Comment 5 Rex Dieter 2011-02-09 14:12:13 EST
rats, still haven't accounted for:
qt4/plugins/designer/libphononwidgets.so
Comment 6 Fedora Update System 2011-02-13 03:48:45 EST
qt-4.7.1-15.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qt-4.7.1-15.fc14
Comment 7 Fedora Update System 2011-02-16 14:19:46 EST
qt-4.7.1-17.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qt-4.7.1-16.fc14
Comment 8 Fedora Update System 2011-02-25 22:56:01 EST
qt-4.7.1-17.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.