Bug 672097 - [abrt] gwibber-1:2.33.0-12.894bzr.fc13: gwui.py:957:error_shortened:NameError: global name 'mark' is not defined
Summary: [abrt] gwibber-1:2.33.0-12.894bzr.fc13: gwui.py:957:error_shortened:NameError...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gwibber
Version: 13
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6866e65c
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-23 22:44 UTC by Wendell Baker
Modified: 2011-05-07 13:25 UTC (History)
5 users (show)

Fixed In Version: gwibber-3.0.0.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-30 05:39:00 UTC


Attachments (Terms of Use)
File: backtrace (808 bytes, text/plain)
2011-01-23 22:44 UTC, Wendell Baker
no flags Details

Description Wendell Baker 2011-01-23 22:44:04 UTC
abrt version: 1.1.14
architecture: i686
cmdline: /usr/bin/python /usr/bin/gwibber
component: gwibber
executable: /usr/bin/gwibber
kernel: 2.6.34.7-56.fc13.i686.PAE
package: gwibber-1:2.33.0-12.894bzr.fc13
reason: gwui.py:957:error_shortened:NameError: global name 'mark' is not defined
release: Fedora release 13 (Goddard)
time: 1295813780
uid: 500

backtrace
-----
gwui.py:957:error_shortened:NameError: global name 'mark' is not defined

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 589, in msg_reply_handler
    *message.get_args_list()))
  File "/usr/lib/python2.6/site-packages/gwibber/gwui.py", line 957, in error_shortened
    iter = buf.get_iter_at_mark(mark)
NameError: global name 'mark' is not defined

Local variables in innermost frame:
dbus_exc: DBusException(dbus.String(u'Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.'),)
buf: <gtk.TextBuffer object at 0x92099b4 (GtkTextBuffer at 0x934fb80)>
text: 'http://www.example.com/f/paper.pdf'

comment
-----
This isn't repeatable.

It does occur sporadically; it seems to be a timing thing between gwibber and dbus somehow.

How to reproduce
-----
1. put in an URL to get it shortened
2. see the crash
3.

Comment 1 Wendell Baker 2011-01-23 22:44:05 UTC
Created attachment 474868 [details]
File: backtrace

Comment 2 Vinzenz Vietzke 2011-01-26 21:42:35 UTC
Package: gwibber-1:2.33.0-12.894bzr.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Pasted URL
2. Gwibber was shortening it via ur1.ca

Comment 3 Terry Wallwork 2011-02-02 09:25:25 UTC
Package: gwibber-1:2.33.0-12.894bzr.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. pasted in a url link that was being shortened, it printed lots of litt = characters repeatly over and over
2.
3.

Comment 4 Theophanis Kontogiannis 2011-02-15 18:41:59 UTC
Package: gwibber-1:2.33.0-12.894bzr.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. copied a link
2. waiting to be translated to short link
3.

Comment 5 Michael 2011-03-09 15:04:56 UTC
Package: gwibber-1:2.33.0-12.894bzr.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. i will only send a msg
2.
3.


Comment
-----
smash the crackers, pls ;)

Comment 6 Fedora Update System 2011-03-25 21:17:32 UTC
gwibber-2.91.92-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gwibber-2.91.92-2.fc13

Comment 7 Fedora Update System 2011-03-25 21:18:07 UTC
gwibber-2.91.92-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gwibber-2.91.92-2.fc14

Comment 8 Fedora Update System 2011-03-25 21:18:42 UTC
gwibber-2.91.92-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gwibber-2.91.92-2.fc15

Comment 9 Fedora Update System 2011-03-26 04:50:10 UTC
Package gwibber-2.91.92-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gwibber-2.91.92-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gwibber-2.91.92-2.fc15
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-03-30 05:38:27 UTC
gwibber-2.91.92-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-04-26 21:33:59 UTC
gwibber-3.0.0.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gwibber-3.0.0.1-1.fc14

Comment 12 Fedora Update System 2011-04-26 21:34:39 UTC
gwibber-3.0.0.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gwibber-3.0.0.1-1.fc15

Comment 13 Fedora Update System 2011-04-26 21:35:18 UTC
gwibber-3.0.0.1-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gwibber-3.0.0.1-1.fc13

Comment 14 Fedora Update System 2011-05-01 03:25:08 UTC
gwibber-3.0.0.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2011-05-07 02:54:23 UTC
gwibber-3.0.0.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2011-05-07 13:24:42 UTC
gwibber-3.0.0.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.