Bug 67213 - plain "kernel" packages seem to miss libredhat-kernel provide
plain "kernel" packages seem to miss libredhat-kernel provide
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-20 23:10 EDT by Adrian Likins
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 12:23:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Likins 2002-06-20 23:10:43 EDT
Stumbled across this while testing some up2date
changes on a 2.1AS chroot on my laptop.

It looks like the i686 glibc packages requires libredhat-kernel	
[root@sludge RPMS]# rpm -qp --requires glibc-2.2.4-26.i686.rpm 
glibc-common = 2.2.4-26
basesystem  
libredhat-kernel.so.1  
/usr/sbin/glibc_post_upgrade  
/sbin/ldconfig  
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

but none of the plain "kernel" packages provide this:

[root@sludge RPMS]# rpm -qp --provides kernel-2.4.9-e.3.i686.rpm 
module-info  
kernel = 2.4.9
kernel-drm = 4.1.0
kernel = 2.4.9-e.3

[root@sludge RPMS]# rpm -qp --provides kernel-2.4.9-e.3.athlon.rpm 
module-info  
kernel = 2.4.9
kernel-drm = 4.1.0
kernel = 2.4.9-e.3


This potentially breaks up2date, depending on if the default install
only includes "kernel" packages or not. If "-smp", "-enterprise" or
"-summit" kernels are included, they provide libredhat-kernel.
Comment 1 Suzanne Hillman 2003-08-13 17:30:05 EDT
Has this been looked at yet? 

In a brief glance, it appears that it is not a problem in Taroon, because glibc
does not require any kernel stuff.

Is this something that is likely to get fixed in the next errata?
Comment 2 Suzanne Hillman 2003-08-13 17:37:07 EDT
However, it is still true that libredhat-kernel is not in the plain kernel
package in Taroon. But, I'm not entirely sure it's supposed to be, since it's
also not in -smp.

Note You need to log in before you can comment on or make changes to this bug.