Bug 67214 - Oracle 9iR2 listener won't start due to /var/tmp permission change
Summary: Oracle 9iR2 listener won't start due to /var/tmp permission change
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: basesystem (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-21 03:27 UTC by Michael Crawford
Modified: 2014-03-17 02:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 22:54:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Crawford 2002-06-21 03:27:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
It appears there's been a change in the permissions on the /var/tmp directory 
since 7.1. I just traced down a problem with the Oracle 9.2.0.1.0 listener, 
which couldn't start due to being unable to create the file /var/tmp/.oracle. I 
noticed that directory had permissions drwxr-xr-t. I changed permissions to 
drwxrwxrwt and it fixed things. 

I checked with another system I set up last week and the permissions were 
correct. That was another Dell model, and I didn't install as many packages. I 
installed nearly everything on the system showing the problem, then went in and 
cleaned out stuff I didn't want (rshd, telnetd, stuff like that) - same as on 
the first system. The problem occurred on almost a clean system - just 
installed yesterday and partially configured for mail, dns, ssh and a few other 
things. It appears some package is overwriting the permissions on that 
directory - for some security reason? Just wondering if I'm breaking anything 
by resetting the permissions to world-writeable...

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Hard to remember what I've done since installing the OS - the problem just 
showed up when I traced the listener connection problem. Suggest checking all 
rpms which set permissions on that file to see which ones may set them 
incorrectly.

I don't know if it's possible to reproduce this without going through a 
complete reinstall and trying to retrace my steps...


Additional info:

Comment 1 Bill Nottingham 2005-01-21 22:54:32 UTC
/var/tmp should be 1777; not sure why it was off in your case.

Sorry about this getting lost.

Closing as WORKSFORME; the filesystem package does have the correct perms.


Note You need to log in before you can comment on or make changes to this bug.