Bug 672174 - JON-241 server cann’t perform commit synchronization with agent for platform
JON-241 server cann’t perform commit synchronization with agent for platform
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
4.0.0
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: ---
Assigned To: Simeon Pinder
Corey Welton
:
Depends On:
Blocks: jon241-bugs
  Show dependency treegraph
 
Reported: 2011-01-24 04:55 EST by Rajan Timaniya
Modified: 2011-10-06 15:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
server log (618.44 KB, application/octet-stream)
2011-01-24 04:55 EST, Rajan Timaniya
no flags Details

  None (edit)
Description Rajan Timaniya 2011-01-24 04:55:56 EST
Created attachment 474937 [details]
server log

Description of problem:
JON-241 server cann’t perform commit synchronization with agent for platform.
2011-01-24 15:12:42,893 WARN  [org.rhq.enterprise.server.discovery.DiscoveryBossBean] Could not perform commit synchronization with agent for platform [dhcp1-1.pnq.redhat.com]
java.lang.reflect.UndeclaredThrowableException
	at $Proxy531.synchronizeInventory(Unknown Source)
	at org.rhq.enterprise.server.discovery.DiscoveryBossBean.updateInventoryStatus(DiscoveryBossBean.java:251)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	. . .
Caused by: java.lang.Exception: java.lang.NoClassDefFoundError: org/rhq/enterprise/server/util/HibernateDetachUtility$SerializationType
	at org.rhq.enterprise.communications.command.client.ClientCommandSenderTask.call(ClientCommandSenderTask.java:112)
	at org.rhq.enterprise.communications.command.client.ClientCommandSenderTask.call(ClientCommandSenderTask.java:55)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	... 1 more
Caused by: java.lang.NoClassDefFoundError: org/rhq/enterprise/server/util/HibernateDetachUtility$SerializationType
	at org.rhq.enterprise.server.agentclient.impl.AgentClientImpl$ExternalizableStrategySendCallback.sending(AgentClientImpl.java:178)
	at org.rhq.enterprise.communications.command.client.ClientCommandSender.executePreSendCallbacks(ClientCommandSender.java:1040)
	at org.rhq.enterprise.communications.command.client.ClientCommandSender.send(ClientCommandSender.java:1084)
	at org.rhq.enterprise.communications.command.client.ClientCommandSenderTask.send(ClientCommandSenderTask.java:229)
	at org.rhq.enterprise.communications.command.client.ClientCommandSenderTask.call(ClientCommandSenderTask.java:107)
	... 6 more
Caused by: java.lang.ClassNotFoundException: Unexpected error during load of: org.rhq.enterprise.server.util.HibernateDetachUtility$SerializationType, msg=class "org.rhq.enterprise.server.util.HibernateDetachUtility$SerializationType"'s signer information does not match signer information of other classes in the same package
	at org.jboss.mx.loading.RepositoryClassLoader.loadClassImpl(RepositoryClassLoader.java:560)
	at org.jboss.mx.loading.RepositoryClassLoader.loadClass(RepositoryClassLoader.java:415)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
	... 11 more
Caused by: java.lang.SecurityException: class "org.rhq.enterprise.server.util.HibernateDetachUtility$SerializationType"'s signer information does not match signer information of other classes in the same package


Version-Release number of selected component (if applicable):
JON-241 (brew build)
https://brewweb.devel.redhat.com//buildinfo?buildID=155058

How reproducible:
Always

Steps to Reproduce:
1) Installed JON-241 server and agent
2) Wait to discover platform
3) Import all discover resources
4) Observe server log and imported resources availability 
  
Actual results:
JON server cann’t perform commit synchronization with agent for platform.
All imported resources shows 'UNKNOWN'. 

Expected results:
JON server should discovery all resources, import those and also show its availability. It should perform commit synchronization with agent for platform.

Additional info:
Please refer attached log file.
Comment 1 Simeon Pinder 2011-01-25 14:59:06 EST
This was resolved with following commits:
release-3.0.0 commit: d820e17ac7723444da38b074020b6f0eed8d8f3c
SVN TAG: JBossON_2_4_1_QA 11112

Jar signing was recently added to mead builds. Three classes had to be moved to different packages to resolve the conflicts.  See commit for more details.
Comment 2 Sudhir D 2011-01-28 09:50:37 EST
Tested on the latest brew build and this issue is fixed. Marking this as verified.
Comment 3 Corey Welton 2011-05-23 21:15:03 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:15:14 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:15:19 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:15:20 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.