Bug 67220 - Right <Alt> key produces NoSymbol
Summary: Right <Alt> key produces NoSymbol
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-21 04:51 UTC by Dmitry Bolkhovityanov
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-10 16:25:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config-4 (4.21 KB, text/plain)
2002-06-24 03:10 UTC, Dmitry Bolkhovityanov
no flags Details
XFree86.0.log (21.80 KB, text/plain)
2002-06-24 03:12 UTC, Dmitry Bolkhovityanov
no flags Details

Description Dmitry Bolkhovityanov 2002-06-21 04:51:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
When installing with keyboard=pc104, layout=us and dead keys disabled, the right
<Alt> key doesn't work as <Alt>.  This is *extremely* inconvenient.

Version-Release number of selected component (if applicable):
XFree86-4.2.0-8

How reproducible:
Always

Steps to Reproduce:
1.Install RHL-7.3 with above keyboard settings.
2.Run "xev".
3.Press right <Alt> when xev window has focus
	

Actual Results:  xev outputs an event with "keycode 113 (keysym 0x0, NoSymbol)"

Expected Results:  there should be "Alt_R" instead of "NoSymbol"

Additional info:

I suspect that this can be caused by Alt/Meta/Win keys change since 4.0.3 (which
was used in 7.1, where everything worked fine), but I'm not so familiar with Xkb. 

Additionally, upon X start the following message appears:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            No Symbols named "nodeadkeys" in the include file "us"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server

The keyboard InputDevice section in XFree86-4 (sans comments):
        Option  "XkbRules"      "xfree86"
        Option  "XkbModel"      "pc104"
        Option  "XkbLayout"     "us"  
        Option  "XkbVariant"    "nodeadkeys"

Of course, I have a simple solution of adding 

keycode 113 = Alt_R
add mod1 = Alt_R

to /etc/X11/Xmodmap, but that's a bit weird.

Comment 1 Mike A. Harris 2002-06-22 08:35:50 UTC
Attach your X server log and config file please.

Comment 2 Dmitry Bolkhovityanov 2002-06-24 03:10:27 UTC
Created attachment 62324 [details]
XF86Config-4

Comment 3 Dmitry Bolkhovityanov 2002-06-24 03:12:08 UTC
Created attachment 62325 [details]
XFree86.0.log

Comment 4 Mike A. Harris 2002-08-07 22:33:58 UTC
Defering for future investigation.  Please notify XFree86.org
of the problem as well, so that more eyes are looking at it.

Comment 5 Mike A. Harris 2003-05-21 15:45:16 UTC
I'm not sure if this problem is no longer in current releases of XFree86 or not,
but there is a chance it is fixed, assuming it is a bug and not misconfiguration.

If the problem is still occuring, if you file a bug report upstream at
http://bugs.XFree86.org I would be more than happy to track it there and
backport any fixes.

Please add the URL of the upstream bug report here if you file one.  Also
please indicate if this is working ok for you now.

Thanks.

Comment 6 Mike A. Harris 2004-01-10 16:25:30 UTC
I'm assuming this problem is no longer present in Fedora Core 1 or
Red Hat Enterprise Linux 3, and closing it as CURRENTRELEASE.

If the problem persists in either of the above OS releases, please
file a bug report to XFree86.org at http://bugs.xfree86.org as per
comment #5 above, and reopen this bug for tracking.


Note You need to log in before you can comment on or make changes to this bug.