Bug 67227 - Pine relocation error
Summary: Pine relocation error
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pine   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-06-21 10:32 UTC by Petri Koistinen
Modified: 2007-04-18 16:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-26 08:25:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petri Koistinen 2002-06-21 10:32:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-5.49 i686; Nav)

Description of problem:
Pine crashes when trying to attach files, use spell check, read files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start pine.
2. Select compose.
3. Go to Attchmnt: field.
4. Press ctrl-T.
5. Pine crashes.

Actual Results:  program name unknown>: relocation error: <main program>:
undefined symbol: lstat

Expected Results:  


Additional info:

pine-4.44-6
rawhide-release-20020620-1

Comment 1 Mike A. Harris 2002-06-22 08:42:41 UTC
This sounds like it might be toolchain related, I've Cc'd Jakub.
A wait+rebuild likely will fix it perhaps.

Comment 2 Jakub Jelinek 2002-06-22 09:42:52 UTC
This means some library or binary is built incorrectly.
There should never be undefined reference to lstat, fstat, stat etc.
If optimizing, those functions are inlined into calls to __lxstat etc. with
specific arguments, for non-optimizing builds lstat etc. are .hidden in
libc_nonshared.a which gets linked from libc.so. But if some library is e.g.
linked with ld -shared without -lc, this might happen (use gcc -shared instead).

Comment 3 Mike A. Harris 2002-07-26 08:25:41 UTC
This problem is not reproduceable with the current pine package
running with the Limbo beta updated to current rawhide.  I'm assuming
whatever the problem might have been that it was transient and is fixed
now.

Testing was performed on the i386 platform since no platform is specified
in the bug report.

Could you confirm this now works for you, and then change the bug
status to RAWHIDE, or change it back to ASSIGNED if the problem persists.


Note You need to log in before you can comment on or make changes to this bug.