Bug 672306 - Scanner capability not detected in HP Deskjet 2050 J510 series All-in-One
Scanner capability not detected in HP Deskjet 2050 J510 series All-in-One
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
14
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-24 14:05 EST by Arnes Arnautović
Modified: 2011-05-31 08:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: hplip-3.11.3a-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-31 08:55:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnes Arnautović 2011-01-24 14:05:07 EST
Description of problem:
Fedora 14 recognizes and is able to use HP Deskjet 2050 J510 All-in-One (printer/scanner/copy) but only printing, NOT scanning. When I run Applications > Graphics > Simple Scan I get message saying: "No scanners detected Please check your scanner is connected and powered on". I tested it on that *other* OS and with the drivers provided for it it works, of course. But since I use Fedora I want to be able to scan from Fedora. I searched the net and found that there is HP Linux Imaging and Printing (HPLIPS) that solves this but only the newest version hplip 3.11.1, and the latest in Fedora repositories is 3.10.9-9.
Perhaps this file will solve the issue. It certainly says so in it's release news: http://sourceforge.net/news/?group_id=149981
I posted a package request in: 
https://fedoraproject.org/wiki/Package_maintainers_wishlist#H-K

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Plug in the HP Deskjet 2050 J510 All-in-One
2. Applications > Graphics > Simple Scan
  
Actual results:
Error message:  "No scanners detected Please check your scanner is connected and powered on"

Expected results:


Additional info:
Comment 1 Jiri Popelka 2011-01-25 05:20:59 EST
hplip-3.11.1 rpms builds are here
https://koji.fedoraproject.org/koji/buildinfo?buildID=215370

Download all rpms for your architecture into one directory and update hplip with:
su -c 'yum --nogpgcheck localupdate *.rpm'
Comment 2 Arnes Arnautović 2011-01-25 06:43:23 EST
Got a "Secure Connection Failed
An error occurred during a connection to koji.fedoraproject.org.

SSL peer was unable to negotiate an acceptable set of security parameters.

(Error code: ssl_error_handshake_failure_alert)"
Comment 3 Jiri Popelka 2011-01-25 06:54:06 EST
I have no problems downloading all x86_64 rpms.
Try it again after a while.
Comment 4 Arnes Arnautović 2011-01-26 19:19:39 EST
Sorry to report so late but after not being able to enter the page you gave me and puzzled by certificate error I searched the net and found this page: 
http://koji.fedoraproject.org/koji/buildinfo?buildID=215370 which is same as yours but it's http protocol not https. Why you could enter it and I not I don't know but the important thing is that now I have the hplip-3.11.1-1.fc14.i686.rpm and all other dependencies. And thank you for adding that new package. I saw somewhere that you did it two days ago so I guess my plea didn't go unanswered. ;)
I' currently installing the packages. Will report did it solve the issue.
Comment 5 Arnes Arnautović 2011-01-26 19:24:54 EST
It's ALIVE!!! xD 
Thank you Jiri once again for adding that package.

Note You need to log in before you can comment on or make changes to this bug.