Bug 67241 - Japanese entries vanished from /usr/share/fonts/ja/TrueType/fonts.dir with some conditions xfs
Japanese entries vanished from /usr/share/fonts/ja/TrueType/fonts.dir with so...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ttmkfdir (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 10:29 EDT by James McDermott
Modified: 2014-08-24 20:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-20 19:58:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James McDermott 2002-06-21 10:29:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-34smp i686)

Description of problem:
Japanese entries vanished from /usr/share/fonts/ja/TrueType/fonts.dir with some
conditions. Then,JDK1.3.1 and 1.4 cannot show Japanese characters. The fonts.dir
was recreated, when the font directory had a newer file than the fonts.dir and
the system (or xfs) was restarted. It is implemented in /etc/rc.d/init.d/xfs,
and it's OK. 
 However, problem is encodings.dir file was deleted at the time. Then,
 the output of ttmkfontdir didn't have Japanese entries. After that, we cannot
use Japanese TrueType fonts.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install ttfonts-ja package
2. Restart xfs (or reboot the system)
# /etc/rc.d/init.d/xfs restart
=> At the time, fonts.dir and fonts.scale were created correctly.
However, "encodings.dir" file was deleted by mkfontdir command in the xfs 
start script.
-----Original encodings.dir flie included in ttfonts-ja ------
jisx0212.1990-0 /usr/X11R6/lib/X11/fonts/encodings/large/jisx0212.1990-0.enc.gz
jisx0208.1990-0 /usr/X11R6/lib/X11/fonts/encodings/large/jisx0208.1990-0.enc.gz
jisx0208.1983-0 /usr/X11R6/lib/X11/fonts/encodings/large/jisx0208.1983-0.enc.gz
jisx0201.1976-0 /usr/X11R6/lib/X11/fonts/encodings/large/jisx0201.1976-0.enc.gz

3.Create a new file under /usr/share/fonts/ja/TrueType/
(or install ttfonts-ja-ricoh. Ricoh fonts were installed in           
"/usr/share/fonts/ja/TrueType/Ricoh" directory. It means there are some new
files under the TrueType directory)
	
4.  Restart xfs again
=> fonts.dir and fonts.scale were recreated. But, no Japanese entries.The
condition of the problem is whether encodings.dir file exists or  not.

Actual Results:  Japanese entries vanished from the fonts.dir.

Expected Results:  Japanese entries should be kept in the fonts.dir.

Additional info:
Comment 1 Akira TAGOH 2002-06-24 03:57:20 EDT
ttmkfdir had this problem. it was already fixed in Raw Hide. Please update
XFree86-font-utils.
Comment 2 Need Real Name 2002-12-03 15:16:18 EST
------- Additional Comment #11 From Glen Johnson(gjohnson@austin.ibm.com) 
2002-09-06 10:39 -------

From Red Hat:
The original issue was that the fonts in the fonts dir went
away. Has this been fixed for you?
This sounds like a different problem. Please clarify.

=================================================
From the bug submitter:
No. This problem still occurs. 
It sounds like the symptom is the same. But, I think the original cause is 
"encodings.dir" file of ttfonts-ja is deleted by mkfontdir command.
Then, the Japanese font entries in fonts.dir will not be created at the next 
time.

Comment 3 Leon Ho 2003-01-20 19:58:39 EST
ttmkfdir in rawhide will fix this problem. Now it won't rely on encodings.dir on that 
directory. 

Note You need to log in before you can comment on or make changes to this bug.