Bug 67243 - netatalk 1.5.3.1 depends on Plan 9's /usr/bin/rc
netatalk 1.5.3.1 depends on Plan 9's /usr/bin/rc
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: netatalk (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 10:46 EDT by msterret
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 10:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
removes acleandir.rc and acleandir.1 from the package (and thus the /usr/bin/rc requirement). (908 bytes, patch)
2002-06-21 10:47 EDT, msterret
no flags Details | Diff

  None (edit)
Description msterret 2002-06-21 10:46:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
netatalk-1.5.3.1/bin/afile/Makefile.in plans to install acleandir.rc
into /usr/bin/acleandir.rc. acleandir.rc is a rc shell script.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm --rebuild --clean netatalk-1.5.3.1-1.src.rpm
2.su -c "rpm -Uvh netatalk-1.5.3.1-1.i386.rpm"
	

Actual Results:  error: failed dependencies:
	/usr/bin/rc   is needed by netatalk-1.5.3.1-1


Expected Results:  clean install/update.

Additional info:

Although this is in rawhide, I think it should be fixed because
the two bugs filed against Red Hat 7.3 for netatalk are resolved
via a suggestion to use the rawhide version.

Patch attached to remove acleandir.rc and acleandir.1 from the install.
Comment 1 msterret 2002-06-21 10:47:57 EDT
Created attachment 62048 [details]
removes acleandir.rc and acleandir.1 from the package (and thus the /usr/bin/rc requirement).
Comment 2 Phil Knirsch 2002-06-25 06:03:01 EDT
Fill fix differently (i will fix the script to use bash).

Thanks,

Read ya, Phil

PS: Also a duplicate of #67009.
Comment 3 Phil Knirsch 2002-06-25 09:13:40 EDT
OK, porting the script to bash will have to wait, i used your suggestion and
patched it now to not install/include acleandir.rc and acleandir.1.

Thanks,

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.