Bug 672439 - Anchors are not set on <task id="">
Anchors are not set on <task id="">
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.5
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jeff Fearn
Misty Stanley-Jones
:
: 702166 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-24 23:49 EST by Misty Stanley-Jones
Modified: 2014-06-18 03:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-25 20:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Misty Stanley-Jones 2011-01-24 23:49:00 EST
Description of problem:

If you give a <task> tag an id attribute, no HTML anchor is set. This means that <xref> tags that reference it point nowhere in particular.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Create a <task id="foo">
2. create an <xref linkend="foo" />
3. Build your book
4. Click the link created by the <xref>. Notice that it goes nowhere.
  
Actual results:


Expected results:


Additional info:

According to jfearn this has to do with overriding of anchor-generation by Publican, to ensure valid HTML. It is related to a similar problem with <formalpara>.
Comment 1 Jeff Fearn 2011-01-27 23:04:41 EST
Tweaked style to set ID in wrapper div in HTML.

Committed revision 1707.
Comment 2 Misty Stanley-Jones 2011-01-28 00:25:08 EST
Verified in revision 1707. Thanks, Jeff!
Comment 3 Jeff Fearn 2011-05-19 04:35:41 EDT
*** Bug 702166 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Fearn 2011-07-01 07:24:12 EDT
Back ported to branches/publican-2x

Committed revision 1797.
Comment 5 Rebecca Newton 2011-07-12 01:59:50 EDT
Verified! Clicking the xref link takes you to the task it is linking to.

Note You need to log in before you can comment on or make changes to this bug.