Bug 67255 - SDL-devel should require XFree86-devel
SDL-devel should require XFree86-devel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: SDL (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 12:00 EDT by Thomas Vander Stichele
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 14:34:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Vander Stichele 2002-06-21 12:00:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
When compiling apps against SDL, SDL pulls in -lX11.  However, XFree86-devel is
not listed in the Requires: for the -devel module.
So when building packages that BuildRequire SDL-devel, the build fails if
XFree86-devel is not installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install a clean build root without XFree86-devel installed
2. build a package that BuildRequires: SDL-devel (and runs the
   sdl-config check in configure)
3. See the check fail because libX11.so can't be found
	

Actual Results:  the check fails

Expected Results:  ideally, it should succeed

Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-07-02 08:31:12 EDT
Agreed, dependency added in 1.2.4-3.
Comment 2 Miloslav Trmac 2004-03-08 14:34:48 EST
Fix confirmed in SDL-1.2.5-9

Note You need to log in before you can comment on or make changes to this bug.