Bug 672585 - RFE: virt-install should try harder to diagnose Permission Denied errors
Summary: RFE: virt-install should try harder to diagnose Permission Denied errors
Status: CLOSED DUPLICATE of bug 598175
Alias: None
Product: Fedora
Classification: Fedora
Component: python-virtinst
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-25 16:49 UTC by Richard W.M. Jones
Modified: 2012-01-25 18:45 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-01-25 18:45:03 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2011-01-25 16:49:24 UTC
Description of problem:

If you try to install from an ISO image located in your home
directory, with the normal permissions on the home directory
(0700) then you'll get a permission denied error like this:

ERROR    internal error Process exited while reading console log output: char device redirected to /dev/pts/4
qemu: could not open disk image /home/rjones/tmp/RHEL6.0-20100922.1-Server-x86_64-DVD1.iso: Permission denied

It was very unclear to me what the permission problem was, since
the file itself was 0644 and had the right SELinux labels.

virt-install could do better here.  Before passing the image to
libvirt, it could walk up the tree checking each file and directory
and warning on possible permissions problems.

Version-Release number of selected component (if applicable):

Actually I'm using RHEL 6:
python-virtinst-0.500.3-7.el6.noarch

Comment 1 Cole Robinson 2012-01-25 18:45:03 UTC

*** This bug has been marked as a duplicate of bug 598175 ***


Note You need to log in before you can comment on or make changes to this bug.