Bug 67260 - new-kernel-pkg does not check mkinitrd success
new-kernel-pkg does not check mkinitrd success
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 12:34 EDT by Eugene Kanter
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 12:34:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2002-06-21 12:34:39 EDT
Description of Problem:

new-kernel-pkg does not check mkinitrd success and may leave system unbootable
if mkinitrd fails.

How Reproducible:

always.

Steps to Reproduce:
1. mount /tmp on /dev/shm
from /etc/fstab:
/dev/shm        /tmp    tmpfs   bind    0       0

2. install (do not upgrade) new kernel

3. ls /boot to check if there is new initrd

Actual Results:

no new initrd created because losetup fails on /dev/shm

Expected Results:

new-kernel-pkg a least reports an error to user....
Comment 1 Erik Troan 2002-06-21 16:51:18 EDT
good point... new-kernel-pkg will no longer run grubby if mkinitrd returns
an error
Comment 2 Eugene Kanter 2002-06-22 18:26:14 EDT
More potential problems, please comment.

Should mkinitrd query temporary filesystem type before it runs losetup on it?
Since mkinitrd always (?) runs as root would be more appropriate to use $HOME or
~ for temporary files if losetup on /tmp or /var/tmp fails?

Another question: What will happen if new-kernel-pkg will not run grubby but
user typed rpm -U kernel-x.x.x ? Will new-kernel-pkg tell rpm that upgrade
failed and old package can not be erased?

Note You need to log in before you can comment on or make changes to this bug.