Bug 672730 - mingw32 boost asio : WinError.h case incorrect
Summary: mingw32 boost asio : WinError.h case incorrect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw32-boost
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Thomas Sailer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-26 04:22 UTC by Anthony Green
Modified: 2011-02-19 01:22 UTC (History)
3 users (show)

Fixed In Version: mingw32-boost-1.44.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-19 01:22:55 UTC


Attachments (Terms of Use)

Description Anthony Green 2011-01-26 04:22:00 UTC
Description of problem:
See upstream ticket https://svn.boost.org/trac/boost/ticket/4491
You can't use boost's asio headers with the linux hosted mingw32 toolchain because Linux has case-sensitive filesystems.  The upstream ticket has the right fix (simply change "WinError.h" to "winerror.h").

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2011-02-09 21:16:03 UTC
mingw32-boost-1.44.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mingw32-boost-1.44.0-2.fc14

Comment 2 Fedora Update System 2011-02-10 21:28:24 UTC
mingw32-boost-1.44.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mingw32-boost'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/mingw32-boost-1.44.0-2.fc14

Comment 3 Fedora Update System 2011-02-19 01:22:51 UTC
mingw32-boost-1.44.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.