Bug 67276 - switchdesk does not allow for mwm
switchdesk does not allow for mwm
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: switchdesk (Show other bugs)
beta3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 15:53 EDT by Joshua Jensen
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 11:57:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2002-06-21 15:53:05 EDT
Description of Problem:

switchdesk does not take into account the possible choice of mwm, even if the
openmotif package (which supplies mwm) is installed.

Version-Release number of selected component (if applicable):

Stock Milan beta 2
Comment 1 Mike A. Harris 2002-10-26 01:34:05 EDT
mwm?  eeeeewwwwww
Comment 2 Joshua Jensen 2002-10-26 19:37:39 EDT
You mean "twm?  eeeeewwwwww", or "Windowmaker?  eeeeewwwwww", or "KDE ...."

The point is, switchdesk is supposed to give you the option.  As much as we all
don't use twm, it should be and is on the list, as it -is- a valid window
manager option if it was installed.  MWM is no different in this regard.
Comment 3 Mike A. Harris 2002-11-03 02:38:50 EST
It's switch*desk*, not switchwindowmanager.  As such, I'm considering
removing all window managers from the next release, and leaving only
GNOME and KDE, which are desktop environments.  Neither twm, mwm,
windowmaker, are desktop environments.

Users can use whatever windowmanager they like by editing .xinitrc
et al.

This isn't written in stone yet, but it's trivial compared to more important
work I have on my plate, and I'd rather spend my time doing real work
than arguing with people about crappy window managers.
Comment 4 Joshua Jensen 2003-01-03 12:32:25 EST
It isn't really an arguement about "crappy window managers" it is about
consistency.  You can't fault someone for wanting a program to consistently deal
with it's tasks.  The question here is:  does switchdesk list window managers
that Red Hat installs, or does switch list just Desktop Environments that Red
Hat installs.

Right now it does neither, and while you should decide with path it should
conform to, fixing it would have to take all of about 10 minutes.  In fact, you
can get me off your back by telling me which way you want to go... and I will
supply the patch.
Comment 5 Mike A. Harris 2003-01-24 11:57:56 EST
Switchdesk is for switching between the 2 desktops that Red Hat supports,
which are KDE and GNOME.  "twm" was present as a legacy fallback, kind of
like a safemode of sorts.

I'd be perfectly happy removing twm from the menu, or even removing
switchdesk entirely.  It's somewhat unnecessary nowadays anyway because
users can choose GNOME/KDE from within gdm/kdm already anyway.  It isn't
a priority however.

I wont add more wm's to switchdesk however.


Note You need to log in before you can comment on or make changes to this bug.