Bug 672763 - Internal microphone not working on Acer D250 and other laptops and netbooks
Summary: Internal microphone not working on Acer D250 and other laptops and netbooks
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib
Version: 14
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-26 09:49 UTC by Perazim
Modified: 2012-08-16 16:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-16 16:40:47 UTC
Type: ---


Attachments (Terms of Use)
Text file of alsa-information (22.15 KB, text/plain)
2011-07-25 16:30 UTC, Stephen Haffly
no flags Details

Description Perazim 2011-01-26 09:49:06 UTC
Description of problem:Internal microphone on Acer D250 and other Acers and laptops not working in Skype and other VOIP applications. Appears to effect only applications that use a mono capture where the hardware has stereo hardware.


Version-Release number of selected component (if applicable):Fedora 14 (and previous versions too)


How reproducible:Always


Steps to Reproduce:Open Skype or Linphone on an Acer D250. The internal microphone does not work.
1.
2.
3.
  
Actual results:


Expected results:


Additional info:After some research, I see that this is a problem on other distributions too. It seems that this is happening only when a stereo microphone is used as the plug in type headsets with mono microphones do not exhibit this problem. It has been observed that in the case of the stereo microphone, one channel is being inverted before mixdown to a mono signal resulting in a cancelling effect and no signal. By turning either the left or right channel down to 0%, this problem disappears. It may be that I have reported the incorrect component name because I do not know where this is happening in the sound system. Somewhere in the sound system there is an inversion of either the left or right channel in the capture.

Comment 1 Maurice James 2011-06-01 03:03:40 UTC
It seems as if this problem is not fixed in 15 either

Comment 2 Stephen Haffly 2011-07-25 16:30:04 UTC
Created attachment 515108 [details]
Text file of alsa-information

Comment 3 Stephen Haffly 2011-07-25 16:32:39 UTC
It also does not work on an Acer Aspire One 722

Is the driver version in the kernel the problem? This thread from Fedora Forum would seem to indicate so. The kernel has the driver at 1.0.23 whereas all the ALSA utilities that are in Fedora 15 are at 1.0.24.

http://forums.fedoraforum.org/showthread.php?t=266682

Comment 4 Stephen Haffly 2011-09-19 23:55:03 UTC
I noticed something of interest. After dumping Gnome Shell and most of Gnome (with the exception of parts needed to keep some software running) in favor of XFCE, I noticed in Alsa mixer, that I had different options for HDA ATI SB (Alsa mixer), including switches for Mic B, Mic C, Mic E, and Mic F. Options are for Mic Boost with a drop-down menu for 0, 10, 20, 30, or 40 dB. I played around with the settings and with the microphone set for Mic F and 40dB boost, I was able to get sound input through the built-in microphone in both Audacity and Skype.

The XFCE mixer plugin for the panelhas the Sound Card listed as Playback: Internal Audio Analog Stereo (PulseAudio), the Mixer track as Master, and the Left-click command to bring up xfce4-mixer.

Comment 5 Maurice James 2011-11-01 15:22:01 UTC
It seems as this is the case with laptop with a mono mic. You need to install alsa gui and lower one mic channel. This fixed the issue for me

Comment 6 Perazim 2011-11-02 07:46:09 UTC
(In reply to comment #5)
> It seems as this is the case with laptop with a mono mic. You need to install
> alsa gui and lower one mic channel. This fixed the issue for me

Yes, this is a workaround (and I have been using this) but somewhere in the sound system, most likely in the driver for specific hardware, a channel is getting inverted before being mixed-down to mono.

Comment 7 Narek Babadjanyan 2011-11-30 11:23:08 UTC
Anyone tried pavucontrol?
BTW Changing priority to high

Comment 8 Stephen Haffly 2011-12-26 03:40:29 UTC
Something changed. I no longer have the same options. Now I have mic, mic 1 and internal mic as the options. I can select the internal mic as an option and I am able to record with Audacity using the internal mic. However, with Skype, I cannot get any microphone input.

Comment 9 Sahil Ahuja 2012-03-11 14:40:38 UTC
I too am in the same situation as Stephen Haffly.

Is there a way to use "Internal mic" as pulseaudio's default audio input (instead of "mic")?

http://forums.fedoraforum.org/showthread.php?t=277474

Comment 10 Sahil Ahuja 2012-03-12 11:23:32 UTC
Posted a separate bug report for AO722 specifically: https://bugzilla.redhat.com/show_bug.cgi?id=802316

Comment 11 Stephen Haffly 2012-03-12 21:25:11 UTC
The solution https://bugzilla.redhat.com/show_bug.cgi?id=802316 worked for me too.

Comment 12 Fedora End Of Life 2012-08-16 16:40:50 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.