Bug 67277 - Need to add restrictions on chars used in VG and LV names
Summary: Need to add restrictions on chars used in VG and LV names
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-06-21 20:05 UTC by James Manning
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-01 04:08:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback during beta2 LVM install (62.16 KB, text/plain)
2002-06-21 20:05 UTC, James Manning
no flags Details

Description James Manning 2002-06-21 20:05:07 UTC
traceback a'coming

IMHO, it looks like the restrictions on physical and logical volume names should
be a *lot* tighter - it's letting me put in \ and ! and ? and lots of other
things I can imagine will be problems, especially when I see the device that
grub lists as the boot target including those characters

Comment 1 James Manning 2002-06-21 20:05:41 UTC
Created attachment 62084 [details]
traceback during beta2 LVM install

Comment 2 James Manning 2002-06-21 20:35:51 UTC
when i allowed the default names for everything, the install worked fine (well,
it's working fine, it's actually installing packages now) so I'd have to imagine
this boils down to not being restrictive enough on the characters allowed in
physical and logical volumes

Comment 3 Michael Fulbright 2002-08-01 04:08:37 UTC
Fixed.  Only allowing letters, digits, '.' or '_'.

Comment 4 Jay Turner 2002-09-05 13:35:14 UTC
Looks like the restrictions are in place for re0904.1.

Comment 5 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.