Bug 672778 - [kernel] ath5k phy0: gain calibration timeout - wireless connectivity lost until reboot
[kernel] ath5k phy0: gain calibration timeout - wireless connectivity lost un...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-26 05:56 EST by Joachim Frieben
Modified: 2012-04-26 19:09 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-2.6.38-0.rc3.git2.1.fc15.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-04 04:21:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for fast channel switch (5.49 KB, patch)
2011-02-03 06:58 EST, Joachim Frieben
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 27382 None None None Never

  None (edit)
Description Joachim Frieben 2011-01-26 05:56:31 EST
Description of problem:
For the two or three latest 2.6.38 RC kernel builds , driver ath5k exhibits calibration timeouts causing the loss of wireless connectivity. Output of log file /var/log/dmesg shows many trailing lines 

  "ath5k phy0: gain calibration timeout .." ,

and NM tries repeatedly to reconnect, alas without success.

Version-Release number of selected component (if applicable):
kernel-2.6.38-0.rc2.git3.2.fc15

How reproducible:
Always.

Steps to Reproduce:
1. Boot system.
2. Connect to AP.
  
Actual results:
NM brings up a wireless connection which only lasts a few minutes.

Expected results:
NM brings up a stable wireless connection.

Additional info:
- Wireless interface is a D-Link DWL-G520 Rev. B4 (Atheros AR2413).
- A system reboot is needed to restore wireless connectivity.
- Upstream bug at https://bugzilla.kernel.org/show_bug.cgi?id=27382 .
- Driver ath5k used to work reliably for kernel-2.6.37-2.fc15.
Comment 1 Joachim Frieben 2011-01-26 08:11:54 EST
Reverting successively to earlier kernel builds, it appears that the issue is present from kernel 2.6.38-0.rc2.git1.3.fc15 on, thus

2.6.38-0.rc2.git1.3.fc15  :  FAILURE
2.6.38-0.rc2.git1.1.fc15  :  SUCCESS

According to the changelog, only a vendor patch has been applied between these two builds:

* Mon Jan 24 2011 Kyle McMartin <kmcmartin redhat com> 2.6.38-0.rc2.git1.3
- Disable usb/pci/acpi autosuspend goo until it can be checked.
Comment 2 Joachim Frieben 2011-01-26 16:39:24 EST
After half a day of using kernel 2.6.38-0.rc2.git1.1.fc15, a gain calibration timeout eventually occurred, too, whereas for more recent kernels it happened within a couple of minutes. This observation supports the conjecture of dealing with a genuine 2.6.38 issue.
Comment 3 Joachim Frieben 2011-02-03 06:58:34 EST
Created attachment 476753 [details]
Patch for fast channel switch

Patch fixing the fast channel fix issue provided by Nick Kossifis at

  https://bugzilla.kernel.org/show_bug.cgi?id=27382#c32 .

Please include it into the next F15 kernel build in order to work around the current issue until it gets fixed upstream. Tge latest kernel-2.6.38-0.rc3.git0.1.fc15 is still affected by this issue making it unusable for people relying on wireless network. Thanks!
Comment 4 Phil V 2012-04-26 18:57:22 EDT
I am finding this problem happening again. 
I updated my system with yum update on 2012-04-25.

lots of "ath5k phy0: gain calibration timeout" in dmesg
GUI manager allows dis/enabling wireless but shows no networks.

I have not used the wireless for some time, so can't say whether it was broken by recent updates, or has been broken a long time. 
F16 x86_64 
I've tried rebooting with kernels from 3.2.10-3  to 3.3.2-6 .
reboots do not help.

Can someone reopen this report?
Comment 5 Phil V 2012-04-26 19:09:34 EDT
In my case, emoving the battery restores network connectivity, as reported in similar bugs from 2009, 2010, 2011:
https://bugzilla.redhat.com/show_bug.cgi?id=478395
https://bugzilla.redhat.com/show_bug.cgi?id=638943
https://bugzilla.redhat.com/show_bug.cgi?id=672778

Note You need to log in before you can comment on or make changes to this bug.