Bug 672823 - missing linker flag -lgio
Summary: missing linker flag -lgio
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtksourceview2   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 716176
TreeView+ depends on / blocked
 
Reported: 2011-01-26 14:39 UTC by Karsten Hopp
Modified: 2012-03-14 11:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 11:32:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build log (46.43 KB, text/plain)
2011-01-26 14:39 UTC, Karsten Hopp
no flags Details
fixes undefined macro G_CONST_RETURN (6.53 KB, patch)
2011-06-30 12:37 UTC, Jiri Skala
no flags Details | Diff
adding necessary libs (1.78 KB, patch)
2011-06-30 12:38 UTC, Jiri Skala
no flags Details | Diff

Description Karsten Hopp 2011-01-26 14:39:51 UTC
Created attachment 475404 [details]
build log

Description of problem:
gtksourceview2 cannot be rebuilt on a current F15/rawhide system

Comment 1 Karsten Hopp 2011-04-19 15:24:58 UTC
this problem still exists. 
AFAIKS the package failed to build during the gcc-4.6 mass rebuild, most likely for the same reason.

Comment 2 Jiri Skala 2011-06-30 12:37:35 UTC
Created attachment 510650 [details]
fixes undefined macro G_CONST_RETURN

This attached patch changes sources in accordance with latest upstream sources in git.

Comment 3 Jiri Skala 2011-06-30 12:38:26 UTC
Created attachment 510651 [details]
adding necessary libs

Comment 4 Jiri Skala 2011-06-30 12:39:53 UTC
Hi Matthias,
could you verify patches. I've tested builds mainly for ppc arch.

Thanks, Jiri

Comment 5 Matthias Clasen 2011-06-30 17:43:47 UTC
I don't do deep introspection integration voodoo; please ask Colin Walters of John Palmieri about that. The patches need to go upstream, anyway.

Comment 6 Jiri Skala 2011-07-01 06:27:55 UTC
(In reply to comment #5)
> I don't do deep introspection integration voodoo; please ask Colin Walters of
> John Palmieri about that. The patches need to go upstream, anyway.

Hi Colin,
will you please have a look at patches in the comments #2, especially #3?

The patch fixing undefined G_CONST_RETURN follows current sources int he git.gnome.org.

The second patch (c#3) fixes errors that could be found in 'Description' of this bug (... <fnc> is defined in DSO ...)

Thanks, Jiri

Comment 7 Jiri Skala 2011-08-16 11:24:15 UTC
still no (re)action done

Comment 8 Henrik Nordström 2011-09-24 19:42:37 UTC
armv7hl secondary arch is also bitten by this, causing a number of packages to not be built due to dependencies on gtksourceview2. The following packages have been identified as depending on gtksourceview2:

unison227 plplot listen pygtksourceview tcpjunk monodevelop mldonkey gnusim8085 rubygem-gtksourceview2 blam gtksourceview-sharp bareftp cduce monodevelop-boo virt-mem gnome-do-docklets ocaml-ocamlnet monodevelop-debugger-mdb gpsdrive gtksourcecompletion ghc-gtksourceview2 mono-tools gget ocaml-lablgtk gnome-do gnome-python2-extras f-spot gummi monodevelop-debugger-gdb freetennis gnome-desktop-sharp giggle gnome-rdp lekhonee-gnome ocaml-cairo ruby-gnome2 ocaml-ocamlgraph perl-PDL-Graphics-PLplot gnome-do-plugins boo alt-ergo rpmdepsize latexila deskbar-applet glom ocaml-preludeml spring-installer revelation mathmap tomboy libgda gtksourceview2-sharp monotone-viz gedit-plugins docky psfex frama-c unison213 ocaml-xmlrpc-light gobby gloobus-preview istanbul ocaml-pxp gtranslator ocaml-json-wheel monodevelop-vala why

Comment 9 Henrik Nordström 2011-09-28 20:30:00 UTC
A more direct list of F15 packages depending on gtksourceview2, excluding indirect dependencies:

boo
denemo
frama-c
ghc-gtksourceview2
giggle
gloobus-preview
gnome-desktop-sharp
gnusim8085
gobby
gtksourcecompletion
gtksourceview2-sharp
gtksourceviewmm
gummi
java-gnome
latexila
lekhonee-gnome
libgda
mathmap
ocaml-lablgtk
pygtksourceview
rubygem-gtksourceview2
ruby-gnome2
tcpjunk


This list is based on F15 GA. It is possible some packages have updates to use gtksourceview3 but many do not.

Comment 10 Peter Robinson 2011-12-12 16:43:37 UTC
Its fixed in F-15 with gtksourceview2-2.11.2-11.fc15 but for F16+ there's another FTBFS now too.

Comment 11 Peter Robinson 2012-03-14 11:32:07 UTC
Fixed now in rawhide/F-17 too


Note You need to log in before you can comment on or make changes to this bug.