Bug 672833 - Satellite show traceback when provisioning fully virtualized Xen Guest
Satellite show traceback when provisioning fully virtualized Xen Guest
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization (Show other bugs)
540
All All
high Severity high
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
: Regression
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2011-01-26 09:55 EST by Marcelo Moreira de Mello
Modified: 2012-04-02 08:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: koan-2.0.7-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-26 12:54:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcelo Moreira de Mello 2011-01-26 09:55:51 EST
Description of problem:

When provisioning a fully virtualized Xen Guest, Satellite 5.4 shows a
traceback error. 

[root@satellite-server ~]# rhn_check  -v 
Package spacewalk-koan-0.2.7-7.el5sat.noarch already installed and latest
version
- looking for Cobbler at http://satellite-server.example.com/cobbler_api
- reading URL:
http://satellite-server.example.com/cblr/svc/op/ks/system/satellite-server.example.com:2:fullvirt
install_tree: http://satellite-server.example.com/ty/5gjpap65
libvirtd (pid  5112) is running...
exceptions.NameError
global name 'DistroManager' is not defined
  File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py", line 193, in
initiate_guest
    k.run()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 338, in run
    self.virt()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 661, in virt
    return self.net_install(after_download)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 580, in
net_install
    after_download(self, profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 659, in
after_download
    self.virt_net_install(profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 1140, in
virt_net_install
    virt_auto_boot =  virt_auto_boot
   File "/usr/lib/python2.4/site-packages/koan/xencreate.py", line 80, in
start_install
    guest = virtinst.FullVirtGuest(installer=DistroManager.PXEInstaller())


Version-Release number of selected component (if applicable):
Red Hat Network Satellite 5.4

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.6 (Tikanga)
# rpm -q spacewalk-koan
spacewalk-koan-0.2.7-7.el5sat
# rpm -q koan
koan-2.0.7-2.el5sat


How reproducible:
100%

Steps to Reproduce:
1. Create a kickstart using Xen FV Guest
2. Try to provision the guest
3. Run rhn_check -v on the host

Actual results:

Satellite show a traceback

Expected results:

Satellite works as expected

Additional info:

The problem does not occurs for Xen Paravirt Guest.
Comment 1 Marcelo Moreira de Mello 2011-01-26 09:56:57 EST
Hello, 

Issue were fixed prior in
https://partner-bugzilla.redhat.com/show_bug.cgi?id=520812

Best Regards, 
Marcelo Moreira de Mello
Comment 4 Marcelo Moreira de Mello 2011-01-26 10:41:12 EST
Hello Milan, 

I tested package and I got this output  below: 

[root@client ~]# rhn_check  -v
Package spacewalk-koan-0.2.7-7.el5sat.noarch already installed and latest version
- looking for Cobbler at http://satellite-server.example.com/cobbler_api
- reading URL: http://satellite-server.example.com/cblr/svc/op/ks/system/satellite-server.example.com:2:fullvirt
install_tree: http://satellite-server.example.com/ty/AGWEcbhF
libvirtd (pid  5112) is running...
- fullvirt mode
libvir: Xen error : Domain not found: xenUnifiedDomainLookupByName
libvir: Xen error : Domain not found: xenUnifiedDomainLookupByUUID
libvir: Xen error : Domain not found: xenUnifiedDomainLookupByName
libvir: Domain Config error : unknown OS type hvm
libvirt.libvirtError
unknown OS type hvm
  File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py", line 193, in initiate_guest
    k.run()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 338, in run
    self.virt()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 657, in virt
    return self.net_install(after_download)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 576, in net_install
    after_download(self, profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 655, in after_download
    self.virt_net_install(profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 1136, in virt_net_install
    virt_auto_boot =  virt_auto_boot
   File "/usr/lib/python2.4/site-packages/koan/xencreate.py", line 202, in start_install
    guest.start_install()
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 633, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
   File "/usr/lib64/python2.4/site-packages/libvirt.py", line 1277, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)

[root@client ~]# rpm -q koan
koan-2.0.7-6.el5sat
[root@client ~]# rpm -q python-virtinst
python-virtinst-0.400.3-11.el5

On the satellite server I got this message: 

[root@satellite-server ~]# cat /var/lib/rhn/tasko/sat/cobbler-sync-bunch/cobbler-sync_374358_err
2011-01-26 11:38:00,058 [DefaultQuartzScheduler_Worker-7] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask  - RuntimeExceptioneError trying to sync to cobbler: XmlRpcException calling cobbler.
java.lang.RuntimeException: XmlRpcException calling cobbler.
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.invokeMethod(CobblerXMLRPCHelper.java:72)
	at com.redhat.rhn.taskomatic.task.CobblerSyncTask.execute(CobblerSyncTask.java:70)
	at com.redhat.rhn.taskomatic.task.RhnJavaJob.execute(RhnJavaJob.java:80)
	at com.redhat.rhn.taskomatic.TaskoJob.execute(TaskoJob.java:168)
	at org.quartz.core.JobRunShell.run(JobRunShell.java:214)
	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:549)
Caused by: 
redstone.xmlrpc.XmlRpcException: The response could not be parsed.
	at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:434)
	at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
	at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.invokeMethod(CobblerXMLRPCHelper.java:69)
	... 5 more
Caused by: 
java.io.IOException: Server returned HTTP response code: 503 for URL: http://satellite-server.example.com:80/cobbler_api
	at java.lang.Throwable.<init>(Throwable.java:67)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1140)
	at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:420)
	... 8 more
2011-01-26 11:38:00,059 [DefaultQuartzScheduler_Worker-7] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask  - re-throwing exception since we havent yet.
2011-01-26 11:38:00,062 [DefaultQuartzScheduler_Worker-7] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask  - XmlRpcException calling cobbler.
2011-01-26 11:38:00,062 [DefaultQuartzScheduler_Worker-7] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask  - redstone.xmlrpc.XmlRpcException: The response could not be parsed.


Thank you. 

Best, 
Marcelo Moreira de Mello
Comment 5 Marcelo Moreira de Mello 2011-01-26 12:39:31 EST
Hello Milan, 


The comment#4 was my fault, since the machine don't have cpu flags for full virtualization. 

Thank you for the heads up. 

Best, 
Marcelo
Comment 6 Milan Zazrivec 2011-01-26 12:54:53 EST
The problem described in the initial comment will be fixed in a shortly
to be released koan-2.0.7-6 (part of rhn-tools errata).

Note You need to log in before you can comment on or make changes to this bug.