Bug 672842 - [Arrandale] X window does not start with kernel 2.6.38-0.rc2.git0.1.fc15.i686.PAE
[Arrandale] X window does not start with kernel 2.6.38-0.rc2.git0.1.fc15.i686...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
15
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-26 10:15 EST by Martin Stransky
Modified: 2011-10-21 11:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-21 11:47:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (123.73 KB, text/plain)
2011-02-14 09:02 EST, Martin Stransky
no flags Details
xorg.0.log (39.72 KB, text/plain)
2011-02-14 09:02 EST, Martin Stransky
no flags Details
Xorg.0.log.old (51.71 KB, text/plain)
2011-02-14 09:05 EST, Martin Stransky
no flags Details
Xorg.9.log (29.21 KB, text/plain)
2011-02-14 09:06 EST, Martin Stransky
no flags Details

  None (edit)
Description Martin Stransky 2011-01-26 10:15:24 EST
Description of problem:
Not sure it's the right component but kernel downgrade helped.

X window (the session) does not start with kernel 2.6.38-0.rc2.git0.1.fc15.i686.PAE, I have a disco on my LCD. gdm seems to work fine but it starts flickering after login.
2.6.37-2.fc15.i686.PAE works fine. Hw is lenovo x201 with i5/IntelGFX.

[komat@dhcp-24-199 ~]$ lspci
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Version-Release number of selected component (if applicable):
kernel 2.6.38-0.rc2.git0.1.fc15.i686.PAE

How reproducible:
Always

Steps to Reproduce:
1. install the kernel
2. login to gdm
3. see the flickering
Comment 1 Chuck Ebbert 2011-02-01 15:48:27 EST
Can you try 2.6.38-rc3 when it becomes available tomorrow?
Comment 2 Chuck Ebbert 2011-02-07 09:14:26 EST
Please try the latest rawhide kernel.
Comment 3 Martin Stransky 2011-02-10 02:45:43 EST
It's still broken with 2.6.38-0.rc3.git4.1.fc15.i686.PAE.
Comment 4 Martin Stransky 2011-02-11 02:24:29 EST
Just to be clear - it appears only on an external LCD monitor connected via VGA cable. Build-in laptop display is ok.
Comment 5 Matěj Cepl 2011-02-12 17:05:22 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 Martin Stransky 2011-02-14 09:02:19 EST
Created attachment 478627 [details]
dmesg output
Comment 7 Martin Stransky 2011-02-14 09:02:58 EST
Created attachment 478628 [details]
xorg.0.log
Comment 8 Martin Stransky 2011-02-14 09:05:52 EST
Created attachment 478629 [details]
Xorg.0.log.old
Comment 9 Martin Stransky 2011-02-14 09:06:41 EST
Created attachment 478630 [details]
Xorg.9.log
Comment 10 Matěj Cepl 2011-03-12 11:42:53 EST
Possibly duplicate of bug 680828?
Comment 11 Martin Stransky 2011-03-29 06:35:29 EDT
Still the same, with 2.6.38.1-6.fc15.i686.PAE
Comment 12 Martin Stransky 2011-05-03 07:19:13 EDT
Still the same with 2.6.38.5-22.fc15.i686.PAE
Comment 13 Martin Stransky 2011-05-19 01:56:22 EDT
Still the same with latest f15 kernel.
Comment 14 Martin Stransky 2011-10-21 11:47:31 EDT
Works now.

Note You need to log in before you can comment on or make changes to this bug.