Bug 67307 - anaconda errors out on kickstart installations
anaconda errors out on kickstart installations
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 21:05 EDT by tanner
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-25 11:14:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (56.38 KB, text/plain)
2002-06-21 21:06 EDT, tanner
no flags Details
Redhat 7.2 kickstart configuration file (1.30 KB, text/plain)
2002-06-24 15:04 EDT, tanner
no flags Details

  None (edit)
Description tanner 2002-06-21 21:05:54 EDT
Traceback (innermost last):
  File "/usr/bin/anaconda", line 620, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/text.py", line 364,
in run
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/dispatch.py", line 2
43, in currentStep
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/dispatch.py", line 1
43, in gotoNext
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/dispatch.py", line 2
08, in moveStep
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/packages.py", line 1
06, in readPackages
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/urlinstall.py", line
 39, in readComps
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/comps.py", line 795,
 in __init__
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/comps.py", line 558,
 in readCompsFile
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/comps.py", line 152,
 in __getitem__
KeyError: abiword


Complete log file will be attached in next message
Comment 1 tanner 2002-06-21 21:06:25 EDT
Created attachment 62104 [details]
anaconda dump
Comment 2 Jeremy Katz 2002-06-24 12:15:31 EDT
Your kickstart config is referencing packages which don't exist in the hdlist
for your install tree.
Comment 3 tanner 2002-06-24 15:03:55 EDT
I think you need to look a little harder at this issue. Forgive me, but I'm not
a clueless newbie and I would not post a bug here unless I did my homework and
researched the problem.

My kickstart is very trivial and it does not make any reference to abiword, the
relevant %package section follows (I'll attach the complete ks.cfg as well):

#
# Package Designation
#
%packages
@ Base

That's it for package references. Just the Base packages

I double checked the comps file, and abiword is in the GNOME group, so I'm not
sure why anaconda is even trying to look for abiword.

I did a diff between my local comps file and the official redhat one:

$ diff -u comps comps.redhat
<nothing>

$ md5sum comps
31fbfbf00dfb61dcd0bd4a45771b01f9  comps

$ md5sum comps.redhat
31fbfbf00dfb61dcd0bd4a45771b01f9  comps.redhat

If you look at the error logs, it's bombing out in comps.py, which I assume is
the code that will read the comps file. I gut tells me there is some sort of
parsing error against the latest comps file.

This all started after the font packages where removed from the distribution
because of the intellectual property problems (see redhat mirror list).

I've genhdlist over my local repository to make sure the hdlist and hdlist2 are
up to date as well.

If you still think this is user error on my part, please let me know what to
change in my ks.cfg to fix the problem. Thanks.


Comment 4 tanner 2002-06-24 15:04:53 EDT
Created attachment 62404 [details]
Redhat 7.2 kickstart configuration file
Comment 5 J. Darrin McDougald 2002-07-25 11:14:30 EDT
I am getting a similar error-out. I even went so far as to limit what was 
being installed to a 326mb base system (Plus Anaconda so I can 
upgrade/add the rest after a sucessful install).

I am installing via NFS. 

I have used valhalla-i386-disk* downloaded from ftp.redhat.com, as well 
as a set from 3 diff mirrors. all with the same results.

I have created 5 diff bootnet discs, all from bootnet.img from diff mirror 
sites.

After Using RedHat daily since 96 I am atleast happy to say this is the only 
failed install Ive ever done. However, since the first BOMB was during an 
upgrade from 7.1 on a system thats had redhat 5, 6, & 7 (with a few minor 
hardware upgrades along the way) I now have NO working Linux box. 

--forced to use my wife's MAC to post--

J. Darrin McDougald
Comment 6 Jeremy Katz 2002-07-25 15:24:14 EDT
We verify that the packages in the comps file are all listed in the header list.  

[katzj@rivendell katzj]$ md5sum comps
247e1c9607984d1928d5d02d20a257e7  comps

This is the comps file currently on the ftp site.
Comment 7 J. Darrin McDougald 2002-07-25 15:57:14 EDT
Ok I finally Found a way around this problem. During install I chose to make my
partitions e2fs not e3fs .... 
I went so far as to install little more than a kernel and a shell under e3 and
EVERYTIME I tried to install it errored out.
With the SAME ISO file, I installed to an e2fs partition (even choosing the
install everything) and voila! it worked.

I reproduced the bug atleast 10 times over the past 50+ hours Ive sleep deprived
myself. first install with e2fs Im up and running (albeit with a bloated system)

~Back under the brim and it feels good~

J. Darrin McDougald

Note You need to log in before you can comment on or make changes to this bug.