Bug 67309 - gnome-panel panel_parse_accelerator not parsing <Modn>
gnome-panel panel_parse_accelerator not parsing <Modn>
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-panel (Show other bugs)
6.1.91
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-06-21 23:57 EDT by Jens Petersen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 18:25:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2002-06-21 23:57:19 EDT
Description of Problem:
When I bind "<mod4>F1" and "<mod4>F2" say to menu_key and "run_key"
respectively (with gconf-editor) the bindings do not work.  Only the
modifiers "<Control>", "<Alt>" and "<Shift>" seems to work, not those
for modN.

Version-Release number of selected component (if applicable):
gnome-panel-2.0.0-2
gtk2-2.0.5-1

How Reproducible:
every time

Steps to Reproduce:
1. change bindings to use "<Mod4>" modifier instead of the default
"<Alt>" in gconf-editor. 

Actual Results:
Menu and run bindings don't work with mod4 modifier.

Expected Results:
Using modN modifiers should work.

Additional Information:
"<ModN>" works in metacity and I note that `panel_parse_accelerator'
("panel_util.c") lacks some of the code in metacity's
`meta_ui_parse_accelerator' ("ui.c"), however looking at gtk's
`gtk_accelerator_parse', I don't see why `panel_parse_accelerator'
shouldn't work, or in other words why the extra modifier code in
`meta_ui_parse_accelerator' is necessary.

<grumble>WIBNI `gtk_accelerator_parse' could handle "<Meta>" too
(and "<Hyper>" perhaps).</grumble>  I'll try to file a separate
RFE for that though.
Comment 1 Havoc Pennington 2002-07-10 17:56:27 EDT
I don't think the bug can be in panel_parse_accelerator() - it just 
calls gtk_accelerator_parse, no strangeness there.

The problem is the IGNORED_MODS #define, see
http://bugzilla.gnome.org/show_bug.cgi?id=87876
Comment 2 Jens Petersen 2002-07-11 03:03:20 EDT
So in the mean time can the ModN keys be moved from IGNORED_MODS
to USED_MODS?

Metacity supports <Meta> now?
Comment 3 Havoc Pennington 2002-07-11 11:18:43 EDT
No, just moving from ignored mods to used mods doesn't work - you do need to
ignore numlock and scroll lock. This is why you have to dynamically sort out
which mods are which.

Metacity supports <ModN>, not <Meta>, it still uses gtk_accelerator_parse(). But
metacity doesn't hardcode the ignored mods, it dynamically locates numlock.
Comment 4 Havoc Pennington 2003-01-07 18:25:54 EST
Should be fixed in rawhide, or if not in the next gnome-panel upstream 
version we get. But 90% sure fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.