Bug 673192 - Dracut fails to create initramfs during @minimal Fedora install
Summary: Dracut fails to create initramfs during @minimal Fedora install
Keywords:
Status: CLOSED DUPLICATE of bug 663357
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-27 17:15 UTC by James Laska
Modified: 2013-09-02 06:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-01 10:38:45 UTC
Type: ---


Attachments (Terms of Use)

Description James Laska 2011-01-27 17:15:17 UTC
Description of problem:

After a rawhide install completes, there is no initramfs created.  Attempting to create it manually from tty2 shows that it fails because 'less' is not installed.

Installing 'less' allows dracut to complete

Version-Release number of selected component (if applicable):
 * dracut-008-0.11.gitb2415f4.fc15

Steps to Reproduce:
1. Download rawhide boot.iso linked from test day page (https://fedoraproject.org/wiki/Test_Day:2011-01-27_Network_Device_Naming_With_Biosdevname#Install_Rawhide)
2. Boot installer using updates.img (required and also linked on the test day page)
3. Select @minimal package set
4. Complete installation
  
Actual results:

System fails to boot.  No initramfs was created.

Expected results:

Initramfs is created

Additional info:

Comment 1 James Laska 2011-01-27 18:52:49 UTC
= Workaround =

1. Prior to rebooting the installer, change to tty2 (<ctrl><alt>F2)
2. chroot /mnt/sysimage /bin/su -
3. dracut /boot/initramfs-$(uname -r).img $(uname -r)
4. cat <<EOF >>/etc/grub.conf
	initrd /initramfs-$(uname -r).img
EOF

Comment 3 Harald Hoyer 2011-01-27 20:29:10 UTC
(In reply to comment #2)
> preferred upstream patch:
> http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=commitdiff;h=07caee2662c97d302cde244a1f7b22f9a089fd3f

wrong patch...

Comment 4 Harald Hoyer 2011-02-01 10:38:45 UTC

*** This bug has been marked as a duplicate of bug 663357 ***


Note You need to log in before you can comment on or make changes to this bug.