Bug 673198 - ntpdate fails to get update with NetworkManager
Summary: ntpdate fails to get update with NetworkManager
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ntp
Version: 6.0
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 947775
TreeView+ depends on / blocked
 
Reported: 2011-01-27 17:26 UTC by Colin.Simpson
Modified: 2013-11-21 09:49 UTC (History)
2 users (show)

(edit)
Cause: 
The ntpdate service didn't wait for NetworkManager to configure the network and gave up when ntpdate failed to set the clock.

Consequence: 
ntpdate may not have access to the Internet when it was run, failing to set the system clock.

Fix: 
If ntpdate fails, try it again few times in increasing intervals.

Result: 
The system clock is set even when NetworkManager takes longer to configure the network.
Clone Of:
(edit)
Last Closed: 2013-11-21 09:49:04 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1593 normal SHIPPED_LIVE ntp bug fix and enhancement update 2013-11-20 21:39:27 UTC

Description Colin.Simpson 2011-01-27 17:26:33 UTC
Description of problem:
Basically copied from a Fedora 13 bug report (same issue)

https://bugzilla.redhat.com/show_bug.cgi?id=445229

ntpdate fails to get update with NetworkManager

Booting up I get an error from ntpdate unable to contact 
NTP server because there is no network up.

How reproducible:
100% of time

Steps to Reproduce:
1. Boot box up
2. Observe failure from ntpdate
  
Actual results:

ntpdate fails to get date/time update

Expected results:

ntpdate should wait for the network to come up.

Additional info:

Seemed to have been fixed in F14 with systemd. Not really an option on RHEL6.

Comment 2 RHEL Product and Program Management 2011-01-27 17:48:26 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Colin.Simpson 2011-01-27 18:10:48 UTC
Well I guess unless it's been addresses for 6.1 it will need moved to that version.

Comment 4 Miroslav Lichvar 2011-01-28 13:47:17 UTC
The same change can be used as the one in Fedora, but it will delay the boot.

Comment 5 RHEL Product and Program Management 2011-07-06 00:07:10 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 7 Suzanne Yeghiayan 2012-02-14 23:06:23 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 11 errata-xmlrpc 2013-11-21 09:49:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1593.html


Note You need to log in before you can comment on or make changes to this bug.