This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 67321 - hf77 generates warning messages about libs not found
hf77 generates warning messages about libs not found
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: lam (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-22 10:29 EDT by Sasko Stefanovski
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-24 19:12:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sasko Stefanovski 2002-06-22 10:29:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
When I execute hf77 compiler I get warning messages complaining that
liblammpi++.* and liblammpio.* are expected to be found in (no location reported
whatsoever), although they are located in /usr/lib.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Just execute hf77
2.
3.
	

Actual Results:  WARNING: hf77 expected to find liblammpi++.* in 
WARNING: MPI C++ API support will be disabled
WARNING: hf77 expected to find liblammpio.* in 
WARNING: MPI-2 IO support will be disabled
/usr/lib/gcc-lib/i386-redhat-linux/2.96/libg2c.a(main.o): In function `main':
main.o(.text+0x2a): undefined reference to `MAIN__'
collect2: ld returned 1 exit status
hf77: No such file or directory


Expected Results:  /usr/lib/gcc-lib/i386-redhat-linux/2.96/libg2c.a(main.o): In
function `main':
main.o(.text+0x2a): undefined reference to `MAIN__'
collect2: ld returned 1 exit status
hf77: No such file or directory

Additional info:

Here is the patch to the bug. Needs to be checked.
Note that variable plib got not assigned value if libhome ="/usr".
Later on in the code it compares that null value with a string and reports not
found warning messages.

--- lam-6.5.6/tools/hf77/hf77.c.WM      Fri Jun 21 14:17:01 2002
+++ lam-6.5.6/tools/hf77/hf77.c Fri Jun 21 14:17:21 2002
@@ -293,11 +293,11 @@
          /* Ensure that we don't -L/usr/lib, for the reasons listed
              above */

+         strcpy(plib[0], LAM_FLIBPATH);
+         strcat(plib[0], libhome);
+         strcat(plib[0], STRSDIR);
+         strcat(plib[0], "lib");
          if (strcmp(libhome, "/usr") != 0) {
-           strcpy(plib[0], LAM_FLIBPATH);
-           strcat(plib[0], libhome);
-           strcat(plib[0], STRSDIR);
-           strcat(plib[0], "lib");
            num_libs = 1;
          }
        }
Comment 1 Trond Eivind Glomsrxd 2002-06-24 19:12:20 EDT
Reported upstream... I remember the introduction of the fix above (adding
/usr/{lib,include} to invocation lines had problems), but it now checks in / for
the libraries instead of just not adding it when running gcc.
Comment 2 Trond Eivind Glomsrxd 2002-06-27 19:14:20 EDT
Fixed in 6.5.6-7 with a patch from the author.

Note You need to log in before you can comment on or make changes to this bug.