Bug 673263 - Munin node returns an empty list of plugins with uppercase hostnames
Summary: Munin node returns an empty list of plugins with uppercase hostnames
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: munin
Version: el5
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-27 21:18 UTC by BK Box
Modified: 2011-02-24 19:54 UTC (History)
2 users (show)

Fixed In Version: munin-1.4.5-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-24 19:53:44 UTC


Attachments (Terms of Use)

Description BK Box 2011-01-27 21:18:18 UTC
Description of problem:

When a server has uppercase letters in the hostname, the munin-node will not match the hostname when asking for a list of plugins.

Version-Release number of selected component (if applicable):

1.4.5

How reproducible:

Every time

Steps to Reproduce:
1.Create a server with hostname containing uppercase letters (i.e. HostName.example.com)
2.Install Munin
3.telnet 0 4949
4.nodes
5.list HostName.example.com
  
Actual results:

*blank*

Expected results:

list of available plugins as defined in /etc/munin/plugins/

Additional info:

This bug has been fixed, but is yet to be released by the munin group:
http://munin-monitoring.org/ticket/952

Comment 1 Kevin Fenzi 2011-02-04 23:19:00 UTC
Can you try the scratch build at: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=2763244

and confirm it fixes this issue?

Comment 2 BK Box 2011-02-07 18:47:17 UTC
This bug is still present in the scratch build packages:

# rpm -q munin-node
munin-node-1.4.5-5.el5
[root@CentOS ~]# rpm -qi munin-node
Name        : munin-node                   Relocations: (not relocatable)
Version     : 1.4.5                             Vendor: Fedora Project
Release     : 5.el5                         Build Date: Fri 04 Feb 2011 05:15:19 PM CST
Install Date: Mon 07 Feb 2011 11:10:17 AM CST      Build Host: x86-05.phx2.fedoraproject.org
Group       : System Environment/Daemons    Source RPM: munin-1.4.5-5.el5.src.rpm
Size        : 1148745                          License: GPLv2 and Bitstream Vera
Signature   : (none)
Packager    : Fedora Project
URL         : http://munin.projects.linpro.no/
Summary     : Network-wide graphing framework (node)

# su - munin --shell=/bin/bash -c munin-cron
[FATAL] There is nothing to do here, since there are no nodes with any plugins.  Please refer to http://munin-monitoring.org/wiki/FAQ_no_graphs at /usr/share/munin/munin-html line 38

When I manually patch the Server.pm file, it runs fine after a munin-node restart:

# grep _list_services /usr/lib/perl5/vendor_perl/5.8.8/Munin/Node/Server.pm
        _list_services($session, lc($1));
# service munin-node restart
# su - munin --shell=/bin/bash -c munin-cron
mkdir /var/lib/munin/localdomain
mkdir /var/www/html/munin/localdomain
mkdir /var/www/html/munin/localdomain/localhost.localdomain
mkdir /var/www/html/munin/localdomain/localhost.localdomain/diskstats_latency
mkdir /var/www/html/munin/localdomain/localhost.localdomain/diskstats_iops
mkdir /var/www/html/munin/localdomain/localhost.localdomain/diskstats_throughput
mkdir /var/www/html/munin/localdomain/localhost.localdomain/diskstats_utilization

Comment 3 Kevin Fenzi 2011-02-07 22:20:43 UTC
Humf. I seem to have missed an important part of the patch. 

Try: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=2768386

If that doesn't work, what _exact_ patch are you applying? ;)

Comment 4 BK Box 2011-02-07 22:42:33 UTC
Awesome!  That one is workin pretty darn good.

Just so you  have it, here is the bug link in Munin:

http://www.munin-monitoring.org/ticket/952

Thank you.

Comment 5 Fedora Update System 2011-02-09 02:44:13 UTC
munin-1.4.5-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-1.4.5-6.el6

Comment 6 Fedora Update System 2011-02-09 03:20:03 UTC
munin-1.4.5-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-1.4.5-5.el5

Comment 7 Fedora Update System 2011-02-09 17:26:59 UTC
munin-1.4.5-5.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update munin'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/munin-1.4.5-5.el5

Comment 8 BK Box 2011-02-09 18:37:54 UTC
I added a comment on the feedback page.

It works for me, but I have to manually restart munin-node for it to take effect.

Comment 9 Fedora Update System 2011-02-24 19:53:39 UTC
munin-1.4.5-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-02-24 19:54:01 UTC
munin-1.4.5-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.