Bug 673268 - Rawhide installer sees pci2#1 and eth1
Rawhide installer sees pci2#1 and eth1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: biosdevname (Show other bugs)
rawhide
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Matt Domsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 501533
  Show dependency treegraph
 
Reported: 2011-01-27 16:43 EST by James Laska
Modified: 2013-09-02 02:53 EDT (History)
13 users (show)

See Also:
Fixed In Version: biosdevname-0.3.7-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 22:50:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.tgz (/tmp/*log) (10.93 KB, application/x-compressed-tar)
2011-01-27 16:43 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2011-01-27 16:43:04 EST
Created attachment 475693 [details]
anaconda.tgz (/tmp/*log)

Description of problem:

Using a kvm guest with 2 NICs, I see one listed as pci2#1 and the other is eth1.  I have no idea if this is expected or not, but it seems unusual.

Version-Release number of selected component (if applicable):
 * anaconda-15.18-1.fc15
 * biosdevname-0.3.6-1.fc15

How reproducible:


Steps to Reproduce:
1. Create a virt guest using 2 NIC's of the same type
2. Initiate a rawhide install (using https://fedoraproject.org/wiki/Test_Day:2011-01-27_Network_Device_Naming_With_Biosdevname)
3. (optional) boot args: ksdevice=pci2#1
  
Actual results:

            ┌────────────────┤ Networking Device ├────────────────┐             
            │                                                     │             
            │ You have multiple network devices on this system.   │             
            │ Which would you like to install through?            │             
            │                                                     │             
            │ eth1 - Ethernet device eth1 - 52:54:00:5f:84:19     │             
            │ pci2#1 - Ethernet device pci2#1 - 52:54:00:a4:29:75 │             
            │                                                     │             
            │    ┌────┐         ┌──────────┐         ┌──────┐     │             
            │    │ OK │         │ Identify │         │ Back │     │             
            │    └────┘         └──────────┘         └──────┘     │             
            │                                                     │             
            │                                                     │             
            └─────────────────────────────────────────────────────┘             


Expected results:

            ┌────────────────┤ Networking Device ├────────────────┐             
            │                                                     │             
            │ You have multiple network devices on this system.   │             
            │ Which would you like to install through?            │             
            │                                                     │             
            │ pci2#1 - Ethernet device pci2#1 - 52:54:00:a4:29:75 │             
            │ pci3#1 - Ethernet device pci3#1 - 52:54:00:5f:84:19 │             
            │                                                     │             
            │    ┌────┐         ┌──────────┐         ┌──────┐     │             
            │    │ OK │         │ Identify │         │ Back │     │             
            │    └────┘         └──────────┘         └──────┘     │             
            │                                                     │             
            │                                                     │             
            └─────────────────────────────────────────────────────┘             


Additional info:

 * Attaching anaconda.tgz which includes ...


-rw-r--r-- root/root      2284 2011-01-27 16:36 tmp/anaconda.log
-rw-r--r-- root/root       494 2011-01-27 16:41 tmp/biosdevname.log
-r--r--r-- root/root       192 2011-01-27 16:38 tmp/cmdline.log
-rw-r--r-- root/root        90 2011-01-27 16:34 tmp/program.log
-rw-r--r-- root/root     40737 2011-01-27 16:34 tmp/syslog
Comment 1 Matt Domsch 2011-01-30 01:06:03 EST
Yes, this is expected, though we want to have biosdevname _not_ suggest names when running inside a guest.  Narendra is working on a patch to detect such and then return exit(4) with no answer.
Comment 2 James Laska 2011-02-15 12:15:49 EST
(In reply to comment #1)
> Yes, this is expected, though we want to have biosdevname _not_ suggest names
> when running inside a guest.  Narendra is working on a patch to detect such and
> then return exit(4) with no answer.

Matt ... did you want to track that patch Narendra is working on in this bug, or elsewhere?  Otherwise, since you not this is expected, should we close this as NOTABUG?

Is there some wiki page that can help users identify whether having mixed biosdevname and classic named devices is expected?  I suspect this will be something people will request for Common_F15_Bugs
Comment 3 Matt Domsch 2011-02-15 12:55:34 EST
Let's track the patch here.

The feature page should have a list of expected device names.  I know I've added some there in the past.  I'll make sure it's there.
Comment 4 Marizol Martinez 2011-02-15 14:20:36 EST
Matt -- Do we have a corresponding BZ for RHEL 6.1? We'll need one. Thanks!
Comment 5 Shyam Iyer 2011-02-17 10:36:34 EST
(In reply to comment #4)
> Matt -- Do we have a corresponding BZ for RHEL 6.1? We'll need one. Thanks!

Already in 6.1 tree so not required.
Comment 6 Marizol Martinez 2011-02-17 10:41:37 EST
Great, thanks Shyam!
Comment 7 Fedora Update System 2011-02-17 11:23:29 EST
biosdevname-0.3.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/biosdevname-0.3.7-1.fc15
Comment 8 Fedora Update System 2011-02-17 17:25:02 EST
biosdevname-0.3.7-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update biosdevname'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/biosdevname-0.3.7-1.fc15
Comment 9 Fedora Update System 2011-02-18 22:50:16 EST
biosdevname-0.3.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.