Bug 67333 - .Xresources ignored when using KDE desktop
Summary: .Xresources ignored when using KDE desktop
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-22 19:39 UTC by William Slough
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 07:06:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description William Slough 2002-06-22 19:39:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en] (X11; I; Linux 2.2.7-1.15 i686)

Description of problem:
With KDE chosen as the default desktop, my $HOME/.Xresources file
is essentially ignored.  I followed a portion of the startx script
and it appears that the "xrdb" merges my .Xresources, but then I
believe that something later on in the initialization of X overrides
my preferences.  

Just out of curiosity, I switched to Gnome, and I note that the
.Xresources file IS honored with that desktop.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Establish a .Xresources file in your home directory
2. Put this line in that file:  emacs.geometry:20x20
3. Start X as usual

	

Actual Results:  A medium-sized emacs window appears

Expected Results:  A smallish (20x20) emacs window should appear

Additional info:

This is kind of a silly example, but it illustrates the problem.  I've
tried putting other, more realistic, things in my .Xresources file and
they all get ignored.

Comment 1 Bernhard Rosenkraenzer 2002-07-01 12:46:22 UTC
KDE writes its own xresources file to allow non-KDE applications to share KDE 
settings to ensure a more consistant look and feel. 
 
If you don't like it, go to KControl > Look & Feel > Colors and deselect 
"Apply colors to non-KDE applications, that way, KDE's settings won't be 
applied to non-KDE applications.

Comment 2 Michael Schwendt 2002-07-19 14:02:11 UTC
What's the latest status of this?

The "KControl > Look & Feel > Colors > Apply colors to non-KDE applications"
doesn't change a thing.

With Valhalla and KDE, my ~/.Xresources file is not being loaded. For instance,
my resource definitions for xterm don't get activated automatically. But as a
work-around I could switch to ~/.Xdefaults (which is deprecated).

With Limbo and KDE, my ~/.Xresources file _is_ loaded again (and ~/.Xdefaults
has been dropped finally).


Comment 3 Ben Levenson 2002-09-05 23:23:45 UTC
I deselected "Apply colors to non-KDE applications" and emacs window
size was affected by the entry in .Xresources.
fix verified.
closing -> RAWHIDE


Comment 4 Michael Schwendt 2002-09-05 23:40:25 UTC
Works for me with updated (null) [but still not with Valhalla, I think].


Comment 5 Michael Schwendt 2002-09-05 23:55:50 UTC
Since the original bug report was for

> Product:  Red Hat Linux
> Version:  7.3

the resolution is wrong, because it is still broken there.

"KControl > Look & Feel > Colors > Apply colors to non-KDE applications" is off.
After KDE log-in, "xrdb -query" returns nothing.

So, while this may be fixed for Milan, what's the proper fix for Valhalla?

Comment 6 Ben Levenson 2002-09-06 04:14:39 UTC
Oops, my mistake. didn't look at the product:version.

Comment 7 Michael Schwendt 2004-08-24 07:06:04 UTC
Red Hat Linux 7.3 has reached end-of-life, and this bug is not
reproducible since Red Hat Linux 8.0. Hence I assume this two years
old ticket is just bugzilla cadaver.



Note You need to log in before you can comment on or make changes to this bug.