Bug 67337 - cups DocumentRoot is /usr/share/doc
cups DocumentRoot is /usr/share/doc
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-22 19:29 EDT by Miloslav Trmac
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 13:05:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmac 2002-06-22 19:29:53 EDT
Description of problem:
The CUPS configuration file which KDE writes is different from the default RH
setup, noticeably it doesn't define the DocumentRoot to be
/usr/share/doc/cups-<version>, which makes the web interface work rather badly.

Version-Release number of selected component (if applicable):
3.0.0-12

Steps to Reproduce:
1.Install cups RPM without additional configuration (the default config file
consists almost entirely of comments only).
2.Open print:/manager, "configure server"
3.Save configuration

Actual Results:  Opening http://localhost:631 and other pages reports errors

Expected Results:  Opening http://localhost:631 produces the CUPS interface
index page

Additional info:

It seems that once the setting is explicitly mentioned in the configuration
file, the KDE tool is able to read it, it just uses different default. Maybe it
would help if the default CUPS config file enumerated all the options
explicitly, even if we want the default values, but it seems rather ugly to me...
Comment 1 Bernhard Rosenkraenzer 2002-07-02 09:28:46 EDT
Fixed in cups-1.1.15-3 (symlink added because other applications will probably 
expect it there, as well).
Comment 2 Miloslav Trmac 2002-07-02 16:33:00 EDT
Sorry for not saying this earlier, but what do web page templates do in
/usr/share/doc anyway? It seems to me that allowing the user to rm -rf
/usr/share/doc without affecting system functionality would follow the principle
of least surprise.
Comment 3 Michael Sweet 2003-04-18 10:43:44 EDT
The templates are in /usr/share/cups/templates.  /usr/share/doc/cups contains
the documentation for CUPS, and CUPS will continue to work just fine without it
(although it will make it more difficult for the user to open the printer status
pages, for example...)
Comment 4 Miloslav Trmac 2003-04-18 15:51:31 EDT
Indeed the situation has changed since the original bug report, but
the templates still reference images placed in /usr/share/cups-1.1.8/images
in the cups-1.1.18-4 package.

Oh, and this probably belongs to cups.
Comment 5 Tim Waugh 2003-10-16 08:19:10 EDT
Is this still an issue?
Comment 6 Miloslav Trmac 2003-10-16 12:14:43 EDT
Yes, as far as I can see.
See /usr/share/doc/cups-1.1.19/{images,*.css,documentation.html,robots.txt}
for some files that _obviously_ should be installed even with rpm -i --excludedocs
(never mind the actual documentation and files I'm not sure about).
Comment 7 Miloslav Trmac 2004-04-08 08:41:53 EDT
Same in  cups-1.1.20-5.1.

Note You need to log in before you can comment on or make changes to this bug.