Bug 67342 - Network works with kernel 2.4.18-4, fails on 2.4.18-5
Network works with kernel 2.4.18-4, fails on 2.4.18-5
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-22 20:27 EDT by William Shubert
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Shubert 2002-06-22 20:27:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
I have been happily running red hat 7.3 with kernels 2.4.18-3, later moving to
2.4.18-4. When I switched to 2.4.18-5 and rebooted, my network failed. All
attempts to contact other systems would be unable to resolve host names (when I
used a host name), or would give "network unreachable" (if I gave an IP
address). Rebooting and choosing 2.4.18-4 under Grub made things work again. I
tried twice to make sure it wasn't a transient problem, both times 2.4.18-5
failed and 2.4.18-4 worked. "dmesg" showed no network startup problems,
"ifconfig" reported exactly the same configuration for each kernel.

Version-Release number of selected component (if applicable): 2.4.18-5


How reproducible:
Always

Steps to Reproduce:
1.Choose kernel 2.4.18-5 under grub.
2.Ping a hostname or an IP address of any machine.



Actual Results:  ping cannot resolve host IP address; if given the IP address,
ping says says "network unreachable"

Expected Results:  ping reports response time.

Additional info:

/proc/pci reports that this is my network card:

  Bus  0, device  12, function  0:
    Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 16).
      IRQ 11.
      Master Capable.  Latency=32.  Min Gnt=32.Max Lat=64.
      I/O at 0xe800 [0xe8ff].
      Non-prefetchable 32 bit memory at 0xe8002000 [0xe80020ff].

Also, note that I'm calling this severity "high". It does not crash, but wihtout
network connectivity this system is pretty much useless (no email, no web
browser, etc.), so crashing would be no worse!!! If you think it should be
normal severity, that's fine go ahead and drop it down.
Comment 1 Bugzilla owner 2004-09-30 11:39:41 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.