Bug 673438 - [vim] gvim unresponsive after start-up
Summary: [vim] gvim unresponsive after start-up
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-28 08:32 UTC by Joachim Frieben
Modified: 2011-10-02 23:02 UTC (History)
12 users (show)

Fixed In Version: vim-7.3.315-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 23:24:58 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 727385 None CLOSED sporadic slow key event processing 2019-05-27 08:54:43 UTC

Internal Links: 727385

Description Joachim Frieben 2011-01-28 08:32:02 UTC
Description of problem:
When opening a text file, gvim is very sluggish. It takes a while until key input is processed (actually in a kind of "burst mode") making it impossible to actually edit the loaded text in reasonable manner. In the meantime, the shell from which gvim had been started is filled with warnings:

(gvim:5333): IBUS-WARNING **: org.freedesktop.IBus.InputContext.ProcessKeyEvent: Timeout was reached

Version-Release number of selected component (if applicable):
vim-X11-7.3.107-1.fc15.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Start GNOME session.
2. Open file in gvim.
3. Move cursor and edit some text.
  
Actual results:
gvim is very sluggish. Key input accumulates until it gets processed after some time in a kind of burst.

Expected results:
gvim allows to edit the text in a fluent manner.

Additional info:
None.

Comment 1 Joachim Frieben 2011-02-08 10:08:41 UTC
Issue has disappeared for current "rawhide" - probably a now resolved problem in the GNOME infastructure as the version of vim-X11 has not changed in the meantime.

Comment 2 Joachim Frieben 2011-02-25 07:22:38 UTC
Fully updated F15 shows significant latencies of various actions within gvim, e.g. when opening the "Find and Replace..." dialog from the "Edit" menu:

(gvim:2821): IBUS-WARNING **: org.freedesktop.IBus.CreateInputContext: Timeout was reached
(gvim:2821): IBUS-CRITICAL **: _create_input_context: assertion `ibusimcontext->ibuscontext != NULL' failed
(gvim:2821): IBUS-WARNING **: org.freedesktop.IBus.CreateInputContext: Timeout was reached
(gvim:2821): IBUS-CRITICAL **: _create_input_context: assertion `ibusimcontext->ibuscontext != NULL' failed

Interestingly, when repeating said operation for the same instance of gvim, the dialog window appears immediately.

Comment 3 Joachim Frieben 2011-02-26 17:03:49 UTC
It should be added that it is impossible to navigate through or to edit a text. The program does not react to keyboard input.

Comment 4 Vít Ondruch 2011-03-14 13:16:18 UTC
I am trying search in GVIM and observe similar oddities:

How reproducible:
Always.

Steps to Reproduce:
1. Start terminal
2. gvim somefile
3. Press '/' for search start.

The following output in my terminal appears:

(gvim:9913): IBUS-WARNING **: org.freedesktop.IBus.InputContext.GetEngine: Časový limit vypršel

(gvim:9913): IBUS-WARNING **: org.freedesktop.IBus.InputContext.GetEngine: Časový limit vypršel

(gvim:9913): IBUS-WARNING **: org.freedesktop.IBus.CreateInputContext: Časový limit vypršel

(gvim:9913): IBUS-CRITICAL **: _create_input_context: assertion `ibusimcontext->ibuscontext != NULL' failed

It takes like 10 seconds before the search itself is possible.

Comment 5 Brian Millett 2011-03-30 15:10:42 UTC
but if launched as root (sudo gvim), there is not slowdown, but very responsive.

Comment 6 Joachim Frieben 2011-03-30 17:54:16 UTC
(In reply to comment #5)
Right, that is what I am seeing, too.

Comment 7 michael o'sullivan 2011-04-17 21:41:05 UTC
gvim is responsive, however, if launched from the Gnome 3 super-key application launcher. It's still non-responsive if launched from a terminal or Alt-F2

Comment 8 Brian Millett 2011-06-02 13:19:15 UTC
Why has this been marked as closed?  It is most frustrating to use gvim with this responsiveness (rather lack of).  It is NOT fixed in 
vim-X11-7.3.138-1.fc15.x86_64

PLEASE RE-OPEN

Comment 9 Vít Ondruch 2011-06-02 14:30:12 UTC
I agree, this is not fixed. It becomes usable as soon as I press '/' but not before.

Comment 10 Joachim Frieben 2011-06-02 14:55:18 UTC
(In reply to comment #9)
Have you enabled updates-testing? The fact that gvim works on my own system now without problem when launched from the shell suggests that the culprit is actually some other component, probably some GNOME infrastructure package for which a more recent build is available in updates-testing.

Comment 11 Vít Ondruch 2011-06-03 09:07:33 UTC
(In reply to comment #10)
No, I don't have enabled updates-testing and I can't see there any GNOME package update which would help to solve this issue.

Comment 12 Joachim Frieben 2011-06-03 10:49:48 UTC
(In reply to comment #11)
As the original reporter of this issue, I recommend you to enable updates-testing and to try it out yourself when you cannot see which package might be responsible. It could be also useful to create a new user account in order to avoid interference with custom settings and to verify whether the issue persists in this case.

Comment 13 Joachim Frieben 2011-06-12 10:05:57 UTC
(In reply to comment #8)
Please retry for current F15: I have reinstalled from scratch with F15 repos "fedora" and "updates" being enabled but not "updates-testing".
Result: gvim behaves absolutely normal.

Comment 14 Brian Millett 2011-06-12 11:07:34 UTC
No go.  Responsiveness is very slow until I press '/', then behavior is normally good.

After pressing the '/', I get the following message:

(gvim:4034): IBUS-WARNING **: Create input context failed: Timeout was reached.

Comment 15 Vít Ondruch 2011-06-13 09:45:03 UTC
I noticed that this problem appears just when GVIM forks from the terminal. If I run gvim with "-f" flag, i.e. no fork, it runs smoothly (but of course do not detach from terminal :/)

Comment 16 Jekyll Wu 2011-06-29 16:18:23 UTC
I have enabled 'update' and 'updates-testing' and is using ibus-1.3.99.20110419-5.fc15.i686 and vim-X11-7.3.138-1.fc15.i686.
It turns out that starting `gvim` from terminal behave quite differently in different desktop environments:

    gnome3          OK
    kde-4.6.4       slow
    xfce-4.8        slow
    enlightenment   OK
    fluxbox         OK
    openbox         slow

This is really weird, or interesting. 

Since gnome3 is the default desktop of fedora 15, maybe this bug was closed without noticing gvim not working well in other desktops.

Hope my finding may give some help.

Comment 17 Vít Ondruch 2011-06-30 08:22:05 UTC
(In reply to comment #16)
I am using Gnome 3 and it is slow, so I cannot confirm your observation.

Comment 18 Rafa Gallego 2011-07-07 13:21:01 UTC
I am using Fedora 15 with kde-4.6.3 and I can confirm this bug.

Comment 19 Karsten Hopp 2011-07-07 15:24:43 UTC
I'm using Fedora 15 with kde-4.6.3 and stilll can't reproduce this issue.
Lets check the exact library versions. 
One of those with a slow gvim, please attach the output of:
ldd /usr/bin/gvim | cut -d ' ' -f 3| xargs rpm -qf| sort | uniq

Comment 20 Rafa Gallego 2011-07-07 15:30:05 UTC
atk-2.0.0-1.fc15.x86_64                                                         
cairo-1.10.2-3.fc15.x86_64
expat-2.0.1-11.fc15.x86_64
fontconfig-2.8.0-3.fc15.x86_64
freetype-2.4.4-4.fc15.x86_64
gdk-pixbuf2-2.23.3-2.fc15.x86_64
glib2-2.28.8-1.fc15.x86_64
glibc-2.14-4.x86_64
gpm-libs-1.20.6-16.fc15.x86_64
gtk2-2.24.4-2.fc15.x86_64
libacl-2.2.49-9.fc15.x86_64
libattr-2.4.44-7.fc15.x86_64
libgcc-4.6.0-9.fc15.x86_64
libICE-1.0.6-3.fc15.x86_64
libpng-1.2.44-3.fc15.x86_64
libselinux-2.0.99-4.fc15.x86_64
libSM-1.2.0-2.fc15.x86_64
libuuid-2.19.1-1.2.fc15.x86_64
libX11-1.4.3-1.fc15.x86_64
libXau-1.0.6-2.fc15.x86_64
libxcb-1.7-2.fc15.x86_64
libXcomposite-0.4.3-2.fc15.x86_64
libXcursor-1.1.11-3.fc15.x86_64
libXdamage-1.1.3-2.fc15.x86_64
libXext-1.2.0-2.fc15.x86_64
libXfixes-5.0-1.fc15.x86_64
libXi-1.4.3-1.fc15.x86_64
libXinerama-1.1.1-2.fc15.x86_64
libXrandr-1.3.1-2.fc15.x86_64
libXrender-0.9.6-2.fc15.x86_64
libXt-1.1.0-1.fc15.x86_64
ncurses-libs-5.8-2.20110319.fc15.x86_64
nss-softokn-freebl-3.12.10-2.fc15.x86_64
pango-1.28.4-1.fc15.x86_64
perl-libs-5.12.4-159.fc15.x86_64
pixman-0.20.2-2.fc15.x86_64
python-libs-2.7.1-7.fc15.x86_64
ruby-libs-1.8.7.334-1.fc15.x86_64
zlib-1.2.5-3.fc15.x86_64

Comment 21 Brian Millett 2011-07-07 15:41:18 UTC
[bpm]$ sudo ldd /usr/bin/gvim | cut -d ' ' -f 3| xargs rpm -qf| sort | uniq
atk-2.0.0-1.fc15.x86_64
cairo-1.10.2-3.fc15.x86_64
expat-2.0.1-11.fc15.x86_64
fontconfig-2.8.0-3.fc15.x86_64
freetype-2.4.4-4.fc15.x86_64
gdk-pixbuf2-2.23.3-2.fc15.x86_64
glib2-2.28.8-1.fc15.x86_64
glibc-2.14-4.x86_64
gpm-libs-1.20.6-16.fc15.x86_64
gtk2-2.24.4-2.fc15.x86_64
libacl-2.2.49-9.fc15.x86_64
libattr-2.4.44-7.fc15.x86_64
libgcc-4.6.0-9.fc15.x86_64
libICE-1.0.6-3.fc15.x86_64
libpng-1.2.44-3.fc15.x86_64
libselinux-2.0.99-4.fc15.x86_64
libSM-1.2.0-2.fc15.x86_64
libuuid-2.19.1-1.2.fc15.x86_64
libX11-1.4.3-1.fc15.x86_64
libXau-1.0.6-2.fc15.x86_64
libxcb-1.7-2.fc15.x86_64
libXcomposite-0.4.3-2.fc15.x86_64
libXcursor-1.1.11-3.fc15.x86_64
libXdamage-1.1.3-2.fc15.x86_64
libXext-1.2.0-2.fc15.x86_64
libXfixes-5.0-1.fc15.x86_64
libXi-1.4.3-1.fc15.x86_64
libXinerama-1.1.1-2.fc15.x86_64
libXrandr-1.3.1-2.fc15.x86_64
libXrender-0.9.6-2.fc15.x86_64
libXt-1.1.0-1.fc15.x86_64
ncurses-libs-5.8-2.20110319.fc15.x86_64
nss-softokn-freebl-3.12.10-2.fc15.x86_64
pango-1.28.4-1.fc15.x86_64
perl-libs-5.12.4-159.fc15.x86_64
pixman-0.20.2-2.fc15.x86_64
python-libs-2.7.1-7.fc15.x86_64
ruby-libs-1.8.7.334-1.fc15.x86_64
zlib-1.2.5-3.fc15.x86_64

Comment 22 Jekyll Wu 2011-07-07 16:07:59 UTC
atk-2.0.0-1.fc15.i686
cairo-1.10.2-3.fc15.i686
expat-2.0.1-11.fc15.i686
fontconfig-2.8.0-3.fc15.i686
freetype-2.4.4-4.fc15.i686
gdk-pixbuf2-2.23.3-2.fc15.i686
glib2-2.28.8-1.fc15.i686
glibc-2.14-4.i686
gpm-libs-1.20.6-16.fc15.i686
gtk2-2.24.4-2.fc15.i686
libacl-2.2.49-9.fc15.i686
libattr-2.4.44-7.fc15.i686
libgcc-4.6.0-10.fc15.i686
libICE-1.0.6-3.fc15.i686
libpng-1.2.44-3.fc15.i686
libselinux-2.0.99-4.fc15.i686
libSM-1.2.0-2.fc15.i686
libuuid-2.19.1-1.3.fc15.i686
libX11-1.4.3-1.fc15.i686
libXau-1.0.6-2.fc15.i686
libxcb-1.7-2.fc15.i686
libXcomposite-0.4.3-2.fc15.i686
libXcursor-1.1.11-3.fc15.i686
libXdamage-1.1.3-2.fc15.i686
libXext-1.2.0-2.fc15.i686
libXfixes-5.0-1.fc15.i686
libXi-1.4.3-1.fc15.i686
libXinerama-1.1.1-2.fc15.i686
libXrandr-1.3.1-2.fc15.i686
libXrender-0.9.6-2.fc15.i686
libXt-1.1.0-1.fc15.i686
ncurses-libs-5.8-2.20110319.fc15.i686
nss-softokn-freebl-3.12.10-2.fc15.i686
pango-1.28.4-1.fc15.i686
perl-libs-5.12.4-159.fc15.i686
pixman-0.20.2-2.fc15.i686
python-libs-2.7.1-7.fc15.i686
ruby-libs-1.8.7.334-1.fc15.i686
zlib-1.2.5-3.fc15.i686

Comment 23 Karsten Hopp 2011-07-07 16:13:21 UTC
ok, I have now the same libraries as the first poster, still no slowdown.
Must be something else...

Comment 24 Vít Ondruch 2011-07-08 07:12:56 UTC
$ ldd /usr/bin/gvim | cut -d ' ' -f 3| xargs rpm -qf| sort | uniq
atk-2.0.0-1.fc15.x86_64
cairo-1.10.2-3.fc15.x86_64
expat-2.0.1-11.fc15.x86_64
fontconfig-2.8.0-3.fc15.x86_64
freetype-2.4.4-4.fc15.x86_64
gdk-pixbuf2-2.23.3-2.fc15.x86_64
glibc-2.14-3.x86_64
glib2-2.28.8-1.fc15.x86_64
gpm-libs-1.20.6-16.fc15.x86_64
gtk2-2.24.4-2.fc15.x86_64
libacl-2.2.49-9.fc15.x86_64
libattr-2.4.44-7.fc15.x86_64
libgcc-4.6.0-9.fc15.x86_64
libICE-1.0.6-3.fc15.x86_64
libpng-1.2.44-3.fc15.x86_64
libselinux-2.0.99-4.fc15.x86_64
libSM-1.2.0-2.fc15.x86_64
libuuid-2.19.1-1.2.fc15.x86_64
libXau-1.0.6-2.fc15.x86_64
libxcb-1.7-2.fc15.x86_64
libXcomposite-0.4.3-2.fc15.x86_64
libXcursor-1.1.11-3.fc15.x86_64
libXdamage-1.1.3-2.fc15.x86_64
libXext-1.2.0-2.fc15.x86_64
libXfixes-5.0-1.fc15.x86_64
libXinerama-1.1.1-2.fc15.x86_64
libXi-1.4.3-1.fc15.x86_64
libXrandr-1.3.1-2.fc15.x86_64
libXrender-0.9.6-2.fc15.x86_64
libXt-1.1.0-1.fc15.x86_64
libX11-1.4.3-1.fc15.x86_64
ncurses-libs-5.8-2.20110319.fc15.x86_64
nss-softokn-freebl-3.12.10-2.fc15.x86_64
pango-1.28.4-1.fc15.x86_64
perl-libs-5.12.4-159.fc15.x86_64
pixman-0.20.2-2.fc15.x86_64
python-libs-2.7.1-7.fc15.x86_64
ruby-libs-1.8.7.334-1.fc15.x86_64
zlib-1.2.5-3.fc15.x86_64

Comment 25 Vít Ondruch 2011-07-08 07:43:59 UTC
BTW I still have a feeling that this issue is related to locale settings, IBus and forking of the GVIM from console. I still receive every time new file is opened the following warning:

(gvim:15318): IBUS-WARNING **: Create input context failed: Timeout was reached.

If I open GVIM and just (slowly) browse around, I never (well I waited 10 minutes at most) get this message. Once I press '/' to begin search, the prompt appears in 7s and from now, the GVIM behaves smooth. After 30s from pressing the '/', the warning appears on my terminal.

So what triggers the slash? Why there is the IBUS warning. Give us please some clue. Then we might be able to help you to debug this issue.

Comment 26 Vít Ondruch 2011-07-08 09:48:42 UTC
I have experimentally remove IBus and GVIM started work smoothly. I have reinstalled IBus, GVIM is lagging. Could you please pay some attention to GVIM <=> IBUS relation?

Comment 27 Joachim Frieben 2011-07-08 11:03:16 UTC
(In reply to comment #26)
This was obvious since the initial report:

 "(gvim:5333): IBUS-WARNING **:
  org.freedesktop.IBus.InputContext.ProcessKeyEvent: Timeout was reached"

Comment 28 Brian Millett 2011-07-08 12:02:25 UTC
just to add more info for my setup, 

if I 'Quit' the ibus-daemon from the status bar applet (don't know what the name is), the menu item in the upper right of my gnome-shell, gvim works as normal.

when I select 'Restart' from said menu applet thingie, gvim pauses until I press '/'

Comment 29 Joachim Frieben 2011-07-10 14:01:11 UTC
I have created a current F15 live CD based upon the standard Fedora kickstart files including "fedora" and "updates" repositories. After pulling in vim-X11 from the running live session, logging out and in again, gvim works absolutely as expected in a GNOME session. This observation holds when I change the keyboard layout from US to German.
I never do system upgrades of an installed Fedora release. I always install Fedora from scratch. Maybe an update issue?

Installed packages related to vim-X11 are:
atk-2.0.0-1.fc15.i686
cairo-1.10.2-3.fc15.i686
expat-2.0.1-11.fc15.i686
fontconfig-2.8.0-3.fc15.i686
freetype-2.4.4-4.fc15.i686
gdk-pixbuf2-2.23.3-2.fc15.i686
glib2-2.28.8-1.fc15.i686
glibc-2.14-4.i686
gpm-libs-1.20.6-16.fc15.i686
gtk2-2.24.4-2.fc15.i686
libacl-2.2.49-9.fc15.i686
libattr-2.4.44-7.fc15.i686
libgcc-4.6.0-9.fc15.i686
libICE-1.0.6-3.fc15.i686
libpng-1.2.44-3.fc15.i686
libselinux-2.0.99-4.fc15.i686
libSM-1.2.0-2.fc15.i686
libuuid-2.19.1-1.3.fc15.i686
libX11-1.4.3-1.fc15.i686
libXau-1.0.6-2.fc15.i686
libxcb-1.7-2.fc15.i686
libXcomposite-0.4.3-2.fc15.i686
libXcursor-1.1.11-3.fc15.i686
libXdamage-1.1.3-2.fc15.i686
libXext-1.2.0-2.fc15.i686
libXfixes-5.0-1.fc15.i686
libXi-1.4.3-1.fc15.i686
libXinerama-1.1.1-2.fc15.i686
libXrandr-1.3.1-2.fc15.i686
libXrender-0.9.6-2.fc15.i686
libXt-1.1.0-1.fc15.i686
ncurses-libs-5.8-2.20110319.fc15.i686
nss-softokn-freebl-3.12.10-2.fc15.i686
pango-1.28.4-1.fc15.i686
perl-libs-5.12.4-159.fc15.i686
pixman-0.20.2-2.fc15.i686
python-libs-2.7.1-7.fc15.i686
ruby-libs-1.8.7.334-1.fc15.i686
zlib-1.2.5-3.fc15.i686

Comment 30 Joachim Frieben 2011-07-10 14:03:19 UTC
(In reply to comment #29)
ibus-1.3.99.20110419-9.fc15.i686
ibus-anthy-1.2.6-2.fc15.i686
ibus-chewing-1.3.9.2-3.fc15.i686
ibus-gtk2-1.3.99.20110419-9.fc15.i686
ibus-gtk3-1.3.99.20110419-9.fc15.i686
ibus-hangul-1.3.1-3.fc15.i686
ibus-libs-1.3.99.20110419-9.fc15.i686
ibus-m17n-1.3.2-5.fc15.i686
ibus-pinyin-1.3.99.20110520-1.fc15.i686
ibus-pinyin-db-android-1.3.99.20110520-1.fc15.noarch
ibus-rawcode-1.3.1.20100707-4.fc15.i686

Comment 31 Jekyll Wu 2011-07-10 14:34:45 UTC
(In reply to comment #29)
> 

Yes, I can confirm launching `gvim` from terminal works well in gnome3. But did you check other environments,  such as those listed in my previous comment #16? 

I have enabled updates-testing, and have vim-x11-7.3.138-1 and ibus-1.3.99.20110419-10. The result is the same as in comment #16.

Comment 32 Joachim Frieben 2011-07-10 14:53:48 UTC
(In reply to comment #31)
I had filed this bug as a gvim/GNOME3 issue which appears to be resolved now. Any remaining issues with other desktop environments are different bugs and should be reported separately.

Comment 33 Brian Millett 2011-07-10 23:12:41 UTC
Really?  resolved?  Don't assume that that is the case.  Thank you for opening it in the first place, but it still exists for others in the GNOME3 environment.

Comment 34 Joachim Frieben 2011-07-11 08:45:10 UTC
(In reply to comment #33)
> .. it still exists for others in the GNOME3 environment.

Have a look at comment 29 and comment 30, please. If this issue persists in the GNOME3 desktop environment, then this is probably an upgrade or an update issue.
I recommend creating a fresh user account to avoid interference with old custom settings. If you do not feel like installing F15 from scratch, then you can still try a current F15 live spin by means of livecd-creator and verify whether gvim exhibits any strange behaviour.

Comment 35 rf 2011-09-01 14:17:40 UTC
I can confirm that this issue persists in ibus and gvim.
A few days ago I switched from GNOME3 to XFCE, and since then I experience this problem which makes gvim unusable for me.

Note that I use ibus with its pinyin chinese IM.

Comment 36 Yufei Yuan 2011-09-17 17:22:58 UTC
I can confirm this is happening on my Fedora 15. I don't like the feeling of the new GNOME3, it looks raw and unpolished so I stick to KDE.

Every time I need to use gvim I have to quit the IBUS applet. It's annoying especially since I cannot find proper menu item to enable the IBUS applet again, until I quit the session and restart X.

Comment 37 Christian Krause 2011-09-21 03:16:30 UTC
I see the same problem in F15 as well.

Please see https://bugzilla.redhat.com/show_bug.cgi?id=727385 for a workaround and a proposed patch to vim to fix the issue. Most likely both bug reports are describing the same issue.

Comment 38 Fedora Update System 2011-09-21 09:56:53 UTC
vim-7.3.315-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/vim-7.3.315-1.fc14

Comment 39 Fedora Update System 2011-09-21 09:57:42 UTC
vim-7.3.315-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/vim-7.3.315-1.fc15

Comment 40 Fedora Update System 2011-09-21 09:58:34 UTC
vim-7.3.315-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/vim-7.3.315-1.fc16

Comment 41 Fedora Update System 2011-09-21 22:14:29 UTC
Package vim-7.3.315-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vim-7.3.315-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/vim-7.3.315-1.fc16
then log in and leave karma (feedback).

Comment 42 Fedora Update System 2011-09-26 23:24:36 UTC
vim-7.3.315-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 43 Yufei Yuan 2011-09-28 00:31:55 UTC
I can confirm that this is fixed on my box.

Comment 44 Fedora Update System 2011-09-30 18:54:22 UTC
vim-7.3.315-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 45 Fedora Update System 2011-10-02 23:01:48 UTC
vim-7.3.315-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.