Bug 673472 - Bring Authen::Krb5 up to date and build EPEL5, 6 packages.
Summary: Bring Authen::Krb5 up to date and build EPEL5, 6 packages.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Authen-Krb5
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simon Wilkinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-28 10:42 UTC by Steve Traylen
Modified: 2011-06-04 01:42 UTC (History)
1 user (show)

Fixed In Version: perl-Authen-Krb5-1.9-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-04 01:41:53 UTC


Attachments (Terms of Use)

Description Steve Traylen 2011-01-28 10:42:48 UTC
Description of problem:

Currently Authen::Krb5 is rawhide with version 1.7.

Please can it be updated to 1.9.

Also while Authen::Krb5 is in EPEL4 it looks like it was never built for EPEL5 or 6.

Applying the patch below to the .spec it builds just fine for F15, EL5 and EL6.


F15: http://koji.fedoraproject.org/koji/taskinfo?taskID=2747276
EL5: http://koji.fedoraproject.org/koji/taskinfo?taskID=2747276
EL6: http://koji.fedoraproject.org/koji/taskinfo?taskID=2747291

It's a trivial upgrade though it seems the "Authen-Krb5-com_err.patch" can be dropped now.


--- perl-Authen-Krb5.spec.ORIG  2011-01-28 11:25:49.000000000 +0100
+++ perl-Authen-Krb5.spec       2011-01-28 11:31:39.000000000 +0100
@@ -1,6 +1,6 @@
 Name:           perl-Authen-Krb5
-Version:        1.7
-Release:        10%{?dist}
+Version:        1.9
+Release:        1%{?dist}
 Summary:        Krb5 Perl module
 License:        GPL+ or Artistic
 Group:          Development/Libraries
@@ -23,7 +23,7 @@
 %setup -q -n Krb5-%{version}

 # Fix the reference to com_err.h to the correct path
-%patch0 -p1
+#%patch0 -p1

 # And the references to /usr/local/bin/perl
 sed -i 's|/usr/local/bin/perl|/usr/bin/perl|' \
@@ -67,6 +67,9 @@
 %{_mandir}/man3/*

 %changelog
+* Fri Jan 28 2011 Steve Traylen <steve.traylen@cern.ch> - 1.9-1
+- Update to 1.9
+
 * Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.7-10
 - 661697 rebuild for fixing problems with vendorach/lib


Many thanks

Steve.

Comment 1 Fedora Update System 2011-02-08 14:59:48 UTC
perl-Authen-Krb5-1.9-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/perl-Authen-Krb5-1.9-1.el6

Comment 2 Fedora Update System 2011-02-08 15:20:49 UTC
perl-Authen-Krb5-1.9-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/perl-Authen-Krb5-1.9-1.el5

Comment 3 Fedora Update System 2011-02-08 18:00:38 UTC
perl-Authen-Krb5-1.9-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Authen-Krb5'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/perl-Authen-Krb5-1.9-1.el5

Comment 4 Fedora Update System 2011-06-04 01:41:48 UTC
perl-Authen-Krb5-1.9-1.el5 has been pushed to the Fedora EPEL 5 stable repository.

Comment 5 Fedora Update System 2011-06-04 01:42:01 UTC
perl-Authen-Krb5-1.9-1.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.