This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 673659 - modesetting not working in f15 kernel with intel video card
modesetting not working in f15 kernel with intel video card
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
15
i586 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-29 06:14 EST by cornel panceac
Modified: 2011-03-17 10:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 10:33:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg with nomodeset (72.72 KB, text/plain)
2011-01-29 06:14 EST, cornel panceac
no flags Details
xorg with kms (?) (21.09 KB, text/plain)
2011-01-29 06:15 EST, cornel panceac
no flags Details
xorg with kms and some more parameters at kernel boot line (21.60 KB, text/plain)
2011-01-29 06:42 EST, cornel panceac
no flags Details
messages (603.73 KB, text/plain)
2011-01-29 14:01 EST, cornel panceac
no flags Details

  None (edit)
Description cornel panceac 2011-01-29 06:14:50 EST
Created attachment 475937 [details]
xorg with nomodeset

Description of problem:
attempting to boot f15 on intel 82852/855GM video card, fails both in text mode and graphics mode.

Version-Release number of selected component (if applicable):

# uname -r
2.6.38-0.rc2.git5.1.fc15.i686

# lspci -nn | grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)

# lsmod | grep -i video
video                  10797  1 i915

# rpm -qa | grep -i intel
xorg-x11-drv-intel-2.14.0-1.fc15.i686

How reproducible:
always

Steps to Reproduce:
1.boot rawhide
2.
3.
  
Actual results:
text mode is a noisy mix between a huge vertical cursor and other random noises. graphics mode (gdm) is a black screen with a arrow mouse cursor moving fine, and a locked keyboard.

Expected results:


Additional info:
if i boot with nomodeset, text mode is ok, gdm displays and works.
the output above is from the system booted with nomodeset.

attempts to boot with kms ends in a system without network connectivity because network manager fails to stay alive during boot. (and f it would be alive, it would fail to connect, i believe).

the system is thinkpad x40, i can not send smolt profile because smolt is broken.
Comment 1 cornel panceac 2011-01-29 06:15:53 EST
Created attachment 475938 [details]
xorg with kms (?)
Comment 2 cornel panceac 2011-01-29 06:42:52 EST
Created attachment 475941 [details]
xorg with kms and some more parameters at kernel boot line

added drm.debug=14 log_buf_len=16M to kernel boot line
Comment 3 Adam Williamson 2011-01-29 11:23:57 EST
Can we get also /var/log/messages from the second setup (drm.debug and log_buf_len). thanks!
Comment 4 cornel panceac 2011-01-29 14:01:48 EST
Created attachment 475961 [details]
messages

as expected, i sent it after booting with nomodeset :)
Comment 5 Adam Williamson 2011-01-29 17:09:46 EST
Thanks. ajax, there are a couple of boots in the log without nomodeset, so the necessary info is there.
Comment 6 cornel panceac 2011-02-07 13:06:51 EST
adam & adam, thank you. now i have gnome-shell on intel 855 !!!
Comment 7 Matěj Cepl 2011-03-17 10:21:21 EDT
(In reply to comment #6)
> adam & adam, thank you. now i have gnome-shell on intel 855 !!!

Does it mean that this bug has been fixed?
Comment 8 cornel panceac 2011-03-17 10:33:34 EDT
yes, the bug was fixed. thank you.

Note You need to log in before you can comment on or make changes to this bug.