Bug 673746 - Qemu-kvm eth1 on guest facing interrupts share problem with other device
Qemu-kvm eth1 on guest facing interrupts share problem with other device
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
14
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-30 06:01 EST by Muzi
Modified: 2013-01-09 18:31 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 07:46:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Muzi 2011-01-30 06:01:06 EST
Description of problem:
i have fully virutalized guest with 2 NIC's eth0 is working but eth1 is
receiving packets not transmitting data and functional due to facing shares
both an interrupt and memory access address with usb device

Version-Release number of selected component (if applicable):0.12.5-1


How reproducible:


Steps to Reproduce:

1. Run VM with two NIC's support
2. On Child up both eth0 and eth1 
3. eth1 not working , interrupts detail mention in Additional info


Actual results:
eth1 is just receiving data not transmitting data

Expected results:
eth1 should be work


Additional info:

cat /proc/interrupts
            CPU0
   0:        219   IO-APIC-edge      timer
   1:          6   IO-APIC-edge      i8042
   4:         88   IO-APIC-edge      serial
   8:          1   IO-APIC-edge      rtc0
   9:          0   IO-APIC-fasteoi   acpi
  10:   32173856   IO-APIC-fasteoi   eth0
  11:     331891   IO-APIC-fasteoi   uhci_hcd:usb1, eth1

As see in 11: eth1 shares interrupts with usb device.

Both eth0 and eth1 using same NIC model as see below

cat /etc/udev/rules.d/70-persistent-net.rules

# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rule written by
anaconda)
# PCI device 0x10ec:0x8139 (8139cp)                                             
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="52:54:00:5f:6e:d3", ATTR{type}=="1", KERNEL=="eth*",
NAME="eth0"                                                                     

# PCI device 0x10ec:0x8139 (8139cp)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="52:54:00:d1:fc:ae", ATTR{type}=="1", KERNEL=="eth*",
NAME="eth1"         

Please suggest, how we will functional eth1 ?

Thanks
Muzi
Comment 1 Cole Robinson 2012-05-21 07:46:25 EDT
Sorry for the lack of response, but F14 is no longer supported. Muzi, if you are still affected by this bug with newer qemu versions (fedora 16 or 17), please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.