Bug 67385 - date("r") returns wrong timezone offset, cause segfault
Summary: date("r") returns wrong timezone offset, cause segfault
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: noarch Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL: http://bugs.php.net/bug.php?id=15362
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-24 02:22 UTC by john
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 16:47:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description john 2002-06-24 02:22:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; .NET 
CLR 1.0.3705)

Description of problem:
date('r') in some timezones causes apache to segfault


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.set timezone +0930
2.use date('r') in PHP script
3.
	

Actual Results:  Apache segfaults
[Sun Jun 23 10:05:15 2002] [notice] child pid 1508 exit signal Segmentation 
fault (11)
[Sun Jun 23 10:05:15 2002] [notice] child pid 1507 exit signal Segmentation 
fault (11)

Expected Results:  No Segfault

Additional info:

See bug report at 
http://bugs.php.net/bug.php?id=15362

If I replace date('r') with strftime('%a, %e %b %Y %T %z') in my scripts apache 
does not segfault.

Comment 1 lok 2002-07-16 00:11:15 UTC
php-4.0.6-15 on RedHat 7.2 exhibits the same behaviour.

Comment 2 lok 2002-07-16 00:35:29 UTC
php-4.2.1-6 on Limbo also exhibits the above behaviour.

Comment 3 Parag Godkar 2002-07-31 06:04:00 UTC
php-4.1.2-0horde1 custom rpm from IMP ( Horde ) webmail System on Red Hat 7.2 
and php-4.1.2-7 on Red Hat 7.3 exibit the same behaviour.

I came across this bug while testing the IMP Webmail System.

Comment 4 Joe Orton 2005-01-25 16:47:29 UTC
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

c) report the bug to the Fedora Legacy project who may wish to
continue maintenance of this package.



Note You need to log in before you can comment on or make changes to this bug.