Bug 673907 - Install from DVD fails: /var/run/dbus/system_bus_socket is missing
Summary: Install from DVD fails: /var/run/dbus/system_bus_socket is missing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Gracik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F15Alpha, F15AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2011-01-31 02:12 UTC by John Reiser
Modified: 2013-07-04 12:53 UTC (History)
7 users (show)

Fixed In Version: lorax-0.3-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-18 18:24:54 UTC


Attachments (Terms of Use)
g/dbus/p from pungi log (after downloads) (5.42 KB, text/plain)
2011-01-31 18:04 UTC, John Reiser
no flags Details

Description John Reiser 2011-01-31 02:12:50 UTC
Description of problem: Install from DVD fails because /var/run/dbus/system_bus_socket does not exist.

Version-Release number of selected component (if applicable):
anaconda-15.18

How reproducible: every time


Steps to Reproduce:
1. compose install DVD from rawhide of 2011-01-30 (Sunday)
2. boot DVD for Fresh Install, Basic devices
3. 
  
Actual results: Messages on text console about /var/run/dbus/system_bus_socket not accessible, followed by Unhanded exception.


Expected results: No complaints, no unhandled exception.


Additional info:
The first suspicious message on text console is:
   [mounting /tmp as tmpfs]
   Failed to start message bus: Failed to bind socket /var/run/dbus/system_bus_socket
   [running install...]

Then there are dozens of messages
  ** (loader:119): WARNING: Couldn't connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
which are double-spaced (or perhaps triple-spaced.)

None of those messages complaining about system_bus_socket appears in the output of dmesg (given on VT2) or in any log file in /tmp.  Using the shell on VT2, the _directory_ /var/run/dbus does not exist.

Comment 1 Chris Lumens 2011-01-31 17:03:48 UTC
Were there any problems pulling the dbus package into your livecd compose?

Comment 2 John Reiser 2011-01-31 18:04:28 UTC
Created attachment 476245 [details]
g/dbus/p from pungi log (after downloads)

Here are all the lines from the pungi log (after the downloads) that have 'dbus'. There is a suspicious line:
   pylorax.yumhelper.DEBUG: erasing package dbus

Version info:
lorax-0.3-1.fc15.noarch

Comment 3 Chris Lumens 2011-01-31 18:15:22 UTC
Huh, that seems weird.

Comment 4 Martin Gracik 2011-01-31 19:46:48 UTC
Ok, with that removing, you have to look at the lines in context

dbus	['/lib/systemd/*']
erasing package dbus
removed /pub/pungi/work/x86_64/yumroot/installroot//lib/systemd/system/dbus.service
removed /pub/pungi/work/x86_64/yumroot/installroot//lib/systemd/system/dbus.socket
removed /pub/pungi/work/x86_64/yumroot/installroot//lib/systemd/system/dbus.target.wants/dbus.socket
removed /pub/pungi/work/x86_64/yumroot/installroot//lib/systemd/system/messagebus.service
removed /pub/pungi/work/x86_64/yumroot/installroot//lib/systemd/system/multi-user.target.wants/dbus.service
removed /pub/pungi/work/x86_64/yumroot/installroot//lib/systemd/system/sockets.target.wants/dbus.socket

Those are the files that get actually removed, not the whole package.
But I guess /var/run/dbus directory is not even in the dbus package. I log all the paths I remove and there is no /var/run/dbus* in the logs. So this means the directory was not created at all.

We create it manually in buildinstall. So looks like I'll have to do that.

Comment 5 Martin Gracik 2011-01-31 20:03:01 UTC
Fixed in lorax-0.4-1

Comment 6 James Laska 2011-02-08 18:28:49 UTC
Tested and confirmed fix using lorax-0.3-3.fc15 (http://koji.fedoraproject.org/koji/packageinfo?packageID=11346)

Comment 7 Adam Williamson 2011-02-11 08:35:57 UTC
Leaving notes on proposed blockers as I won't be at the meeting tomorrow most
likely:

Obvious +1 blocker.

Comment 8 Dennis Gilmore 2011-02-11 18:41:10 UTC
this probably should be fixed in dbus  and have it provide /var/run/dbus/ since it needs it.

Comment 9 Robyn Bergeron 2011-02-11 19:45:02 UTC
Per 2011-02-11 Alpha blocker meeting - 
# AGREED: 673907 accepted as F15Alpha blocker as this impacts all installs
# clumens and dgilmore reviewing whether an additional/different fix is required

Comment 10 James Laska 2011-02-15 18:59:07 UTC
Confirmed fixed in anaconda-15.20

Comment 11 James Laska 2011-02-18 18:24:54 UTC
Fixed and included in F15Alpha


Note You need to log in before you can comment on or make changes to this bug.