Bug 67401 - nsswitch.conf need not contain nisplus by default
nsswitch.conf need not contain nisplus by default
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-24 10:53 EDT by Joshua Jensen
Modified: 2016-11-24 09:47 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.3.2-27.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-17 14:49:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2002-06-24 10:53:26 EDT
Description of Problem:

"nisplus" is virtually never used, but always in /etc/nsswitch.conf.  Why?
Couldn't we eliminate the overhead of referencing nisplus for the 99.99% of
machines that don't use it?  For that matter, could we add "nisplus nis" _only_
NIS is enabled via authconfig?  This seems like it addresses more of the
authentication scenerios, more of the time.

Version-Release number of selected component (if applicable):

Milan, beta 2
Comment 1 Nalin Dahyabhai 2002-06-24 10:56:30 EDT
authconfig will add NIS to nsswitch.conf, but because it can not configure
nisplus, it leaves nisplus in nsswitch.conf if it finds it there.
Comment 2 Joshua Jensen 2002-06-24 13:08:19 EDT
I understand that authconfig will leave nisplus there if its *already* there...
this is as it should be.  My argument is against it being there by default.  If
someone adds it, sure:  leave it there.  

But... if nisplus can't be configured in any other way than manually, why not
have the administrator configure the machine for nisplus and add "nisplus" to
nsswitch.conf themselves.  Since we can't setup nisplus through authconfig, why
do the first 5% of the job ourselves, when %99.99 percent of RHL machines will
pay a small penality because of it?

If we are already telling NIS+ admins that they have to set it up themselves...
we wouldn't really inconvenience them by not adding a step that we shouldn't be
doing for the vast majority of machines anyway.

My 2,

Joshua

Comment 3 Jakub Jelinek 2002-07-01 07:58:10 EDT
Shouldn't authconfig at least allow checking whether or not to use NIS+ and
tell what needs to be done to configure NIS+?
Comment 4 Joshua Jensen 2003-02-11 19:19:40 EST
The new beta still has the same issue... why list it if has to be setup manually
anyway?
Comment 5 Ulrich Drepper 2003-04-17 14:49:35 EDT
At least the current release doesn't use use nisplus anymore.  Therefore I close
this bug.

Note You need to log in before you can comment on or make changes to this bug.