Bug 67406 - xfs font server could not open default font 'fixed'
xfs font server could not open default font 'fixed'
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-24 11:44 EDT by C Cowley
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-10 09:23:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description C Cowley 2002-06-24 11:44:28 EDT
Description of Problem:

Since installing the latest errata packages via the up2date 
mechanism, the Gnome desktop does not work.  On boot-up the system attempts to load Gnome, but 
after a couple of attempts fails back to text only mode.

The /var/log/XFree86.0.log 
contains the following error:

Fatal server error:
could not open default font 
'fixed'

This ONLY occurs after installing the latest errata from up2date.

Version-
Release number of selected component (if applicable):

XFree86-xfs-4.1.0-25


How 
Reproducible:

Always reproducible after executing up2date after fresh install of RedHat 
7.2

Steps to Reproduce:
1. Install RedHat 7.2
2. Register with and use up2date 
(excluding installation of kernel updates).
3. Reboot system

Actual 
Results:

Gnome desktop will not execute.

Expected Results:

Gnome desktop should 
fire up as system enters run level 5.

Additional Information:
Comment 1 Mike A. Harris 2002-07-10 09:23:32 EDT
Whenever you upgrade XFree86, you must either reboot the machine, or else
restart both xfs, and XFree86.  If this does not solve the problem, then
you need to troubleshoot what is causing the problem and provide that
information in the bug report.  I am unable to reproduce this when doing
a fresh install, plus update, and then properly rebooting the system.
Comment 2 Mike A. Harris 2002-09-05 15:40:35 EDT
xfs works for me on a clean install, after running up2date to
update everything and then performing a clean system reboot.

Note You need to log in before you can comment on or make changes to this bug.